Toolbox.Declarations Namespace

Interfaces
 | Interface | Description
Public interface | ITbExtraActionResult | Definition of a result produced by the extra action sub-system
Public interface | ITbObjectId | Definition for the Toolbox object identifier.
Enumerations
 | Enumeration | Description
Public enumeration | TbServerMode | The Toolbox server mode: single or multi user


ITbExtraActionResult Interface

Definition of a result produced by the extra action sub-system

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbExtraActionResult

The ITbExtraActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Explainer | Name of client's plugin (ITbExtraActionResultExplainPlugin) which can explain this result
Public property | Payload | string encoded result.
Public property | Result | integer result
Top
See Also

Reference

Toolbox.Declarations Namespace


ITbExtraActionResult Properties

The ITbExtraActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Explainer | Name of client's plugin (ITbExtraActionResultExplainPlugin) which can explain this result
Public property | Payload | string encoded result.
Public property | Result | integer result
Top
See Also

Reference

ITbExtraActionResult Interface
Toolbox.Declarations Namespace


ITbExtraActionResult.Explainer Property

A Sandcastle Documented Class Library

ITbExtraActionResultExplainer Property

Name of client's plugin (ITbExtraActionResultExplainPlugin) which can explain this result

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Explainer { get; }

Property Value

Type: String
See Also

Reference

ITbExtraActionResult Interface
Toolbox.Declarations Namespace


ITbExtraActionResult.Payload Property

ITbExtraActionResultPayload Property

string encoded result.

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Payload { get; }

Property Value

Type: String
See Also

Reference

ITbExtraActionResult Interface
Toolbox.Declarations Namespace


ITbExtraActionResult.Result Property

ITbExtraActionResultResult Property

integer result

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
int Result { get; }

Property Value

Type: Int32
See Also

Reference

ITbExtraActionResult Interface
Toolbox.Declarations Namespace


ITbObjectId Interface

Definition for the Toolbox object identifier.

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectId

The ITbObjectId type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption of the object. This will be used for visualization purposes when displaying the toolbox object within the Toolbox client UI.
Public property | Guid | Object unique identifier. Should persist between application runs.
Public property | Version | Object version
Top
See Also

Reference

Toolbox.Declarations Namespace


ITbObjectId Properties

The ITbObjectId type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption of the object. This will be used for visualization purposes when displaying the toolbox object within the Toolbox client UI.
Public property | Guid | Object unique identifier. Should persist between application runs.
Public property | Version | Object version
Top
See Also

Reference

ITbObjectId Interface
Toolbox.Declarations Namespace


ITbObjectId.Caption Property

ITbObjectIdCaption Property

Caption of the object. This will be used for visualization purposes when displaying the toolbox object within the Toolbox client UI.

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Caption { get; }

Property Value

Type: String
See Also

Reference

ITbObjectId Interface
Toolbox.Declarations Namespace


ITbObjectId.Guid Property

ITbObjectIdGuid Property

Object unique identifier. Should persist between application runs.

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Guid Guid { get; }

Property Value

Type: Guid
See Also

Reference

ITbObjectId Interface
Toolbox.Declarations Namespace


ITbObjectId.Version Property

ITbObjectIdVersion Property

Object version

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Version Version { get; }

Property Value

Type: Version
See Also

Reference

ITbObjectId Interface
Toolbox.Declarations Namespace


TbServerMode Enumeration

The Toolbox server mode: single or multi user

Namespace: Toolbox.Declarations
Assembly: Toolbox.Declarations (in Toolbox.Declarations.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public enum TbServerMode
Members
Member name | Value | Description
SingleUser | 0 | user can create/edit TB objects (for example: profilers, QSARs)
MultiUser | 1 | New Toolbox objects cannot be created and existing cannot be modified
See Also

Reference

Toolbox.Declarations Namespace


Toolbox.Docking.Api Namespace

Interfaces
Interface Description
Public interface IToolboxAddin

This is the main Toolbox addin mechanism for third party Toolbox modules.

Upon Toolbox start the Server application scans the ..\Toolbox Server\bin\Addins\ sub-folder of the Server binaries folder. Resulting in a list of sub-folders, each Addin assembly being in its own sub-folder e.g.:

  1. ..\Addins\ThirdPartyProfilerAddinA\ThirdPartyProfilerAddinA.dll
  2. ..\Addins\ThirdPartyProfilerAddinB\ThirdPartyProfilerAddinB.dll
  3. ..\Addins\ThirdPartyProfilerAddinC\ThirdPartyProfilerAddinC.dll

The scanner will then traverse the folder tree and load all assemblies searching for types that implement the IToolboxAddin interface.

After the scanner enumerates the third party assemblies it will construct the IToolboxAddin implementers and pull the available ITbObjectFactory objects via the GetToolboxObjectFactories method.


IToolboxAddin Interface

This is the main Toolbox addin mechanism for third party Toolbox modules.

Upon Toolbox start the Server application scans the ..\Toolbox Server\bin\Addins\ sub-folder of the Server binaries folder. Resulting in a list of sub-folders, each Addin assembly being in its own sub-folder e.g.:

  1. ..\Addins\ThirdPartyProfilerAddinA\ThirdPartyProfilerAddinA.dll
  2. ..\Addins\ThirdPartyProfilerAddinB\ThirdPartyProfilerAddinB.dll
  3. ..\Addins\ThirdPartyProfilerAddinC\ThirdPartyProfilerAddinC.dll

The scanner will then traverse the folder tree and load all assemblies searching for types that implement the IToolboxAddin interface.

After the scanner enumerates the third party assemblies it will construct the IToolboxAddin implementers and pull the available ITbObjectFactory objects via the GetToolboxObjectFactories method.

Namespace: Toolbox.Docking.Api
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface IToolboxAddin

The IToolboxAddin type exposes the following members.

Methods
 | Name | Description
Public method | GetToolboxObjectFactories | This method returns the object factories provided by the addin
Top
Remarks
The Toolbox scanning sub-system would create IToolboxAddin instances via a call to Activator.CreateInstance which means that implementing classes should provide a default parameterless constructor.
See Also

Reference

Toolbox.Docking.Api Namespace


IToolboxAddin Methods

The IToolboxAddin type exposes the following members.

Methods
 | Name | Description
Public method | GetToolboxObjectFactories | This method returns the object factories provided by the addin
Top
See Also

Reference

IToolboxAddin Interface
Toolbox.Docking.Api Namespace


IToolboxAddin.GetToolboxObjectFactories Method

IToolboxAddinGetToolboxObjectFactories Method

This method returns the object factories provided by the addin

Namespace: Toolbox.Docking.Api
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IEnumerable<ITbObjectFactory> GetToolboxObjectFactories()

Return Value

Type: IEnumerable ITbObjectFactory
Returns the list of Toolbox objects the addin supplies.
See Also

Reference

IToolboxAddin Interface
Toolbox.Docking.Api Namespace


Toolbox.Docking.Api.Chemical Namespace

Classes
 | Class | Description
Public class | Chemical | Third party modules SHOULD NOT construct this class. All instances of the Chemical class should be constructed via the ITbCalcService's CreateChemical(String, String) method.
Public class | ChemicalWithData | Represent chemical from QSAR training set and test set.
Enumerations
 | Enumeration | Description
Public enumeration | ChemicalType | Toolbox chemical type enumeration.


Chemical Class

Third party modules SHOULD NOT construct this class. All instances of the Chemical class should be constructed via the ITbCalcService's CreateChemical(String, String) method.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ChemicalChemical

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class Chemical

The Chemical type exposes the following members.

Constructors
 | Name | Description
Public method | Chemical | Constructor for a Toolbox Chemical. DO NOT use this. Use ITbCalcService's CreateChemical(String, String) method instead.
Top
Properties
 | Name | Description
Public property | ChemicalType | The chemical's substance type.
Public property | Smiles | Chemical's structure.
Public property | UniqueId | The unique identifier for the chemical.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Chemical Namespace


Chemical Constructor

Constructor for a Toolbox Chemical. DO NOT use this. Use ITbCalcService's CreateChemical(String, String) method instead.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Chemical(
    Guid uniqueId,
    ChemicalType substanceType,
    string smiles
)

Parameters

uniqueId
Type: SystemGuid
Unique ID for the chemical.
substanceType
Type: Toolbox.Docking.Api.ChemicalChemicalType
Chemical substance type.
smiles
Type: SystemString
Input SMILES.
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


Chemical Properties

The Chemical type exposes the following members.

Properties
 | Name | Description
Public property | ChemicalType | The chemical's substance type.
Public property | Smiles | Chemical's structure.
Public property | UniqueId | The unique identifier for the chemical.
Top
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


Chemical.ChemicalType Property

ChemicalChemicalType Property

The chemical's substance type.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ChemicalType ChemicalType { get; }

Property Value

Type: ChemicalType
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


Chemical.Smiles Property

ChemicalSmiles Property

Chemical's structure.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Smiles { get; }

Property Value

Type: String
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


Chemical.UniqueId Property

ChemicalUniqueId Property

The unique identifier for the chemical.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Guid UniqueId { get; }

Property Value

Type: Guid
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


Chemical Methods

The Chemical type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Chemical Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalType Enumeration

Toolbox chemical type enumeration.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum ChemicalType
Members
Member name | Value | Description
Unknown | 0 | Unknown chemical type
MonoConstituent | 1 | Chemical is defined as mono constituent
MultiConstituent | 2 | Chemical is defined as multi constituent
Polymer | 3 | Chemical is a polymer
Uvcb | 4 | Chemical is a UVCB
MetaboliteSet | 100 | system types, only objects generated from Toolbox server can have these
TautomericSet | 101 | system types, only objects generated from Toolbox server can have these
Other | 255 | system types, only objects generated from Toolbox server can have these
See Also

Reference

Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData Class

Represent chemical from QSAR training set and test set.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ChemicalChemicalWithData

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ChemicalWithData

The ChemicalWithData type exposes the following members.

Constructors
 | Name | Description
Public method | ChemicalWithData | Constructor for a Toolbox ChemicalWithData.
Top
Properties
 | Name | Description
Public property | CasNumber | The chemical's Chemical Abstracts Service registry number.
Public property | ChemicalNames | The list of names for the chemical.
Public property | Smiles | SMILES representation of the chemical's structure.
Public property | XValues | Values of X descriptors used to derive QSAR.
Public property | YValue | Measured values of QSAR.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData Constructor

Constructor for a Toolbox ChemicalWithData.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public ChemicalWithData(
    int cas,
    IEnumerable<string> names,
    string smiles,
    TbDescribedData[] xValues,
    TbDescribedData yValue
)

Parameters

cas
Type: SystemInt32
Chemical Abstracts Service registry number.
names
Type: System.Collections.GenericIEnumerable String
The list of names for the chemical.
smiles
Type: SystemString
SMILES representation of the chemical's structure.
xValues
Type: Toolbox.Docking.Api.DataTbDescribedData
Values of X desriptors used to derive QSAR.
yValue
Type: Toolbox.Docking.Api.DataTbDescribedData
Measured values of QSAR.
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData Properties

The ChemicalWithData type exposes the following members.

Properties
 | Name | Description
Public property | CasNumber | The chemical's Chemical Abstracts Service registry number.
Public property | ChemicalNames | The list of names for the chemical.
Public property | Smiles | SMILES representation of the chemical's structure.
Public property | XValues | Values of X descriptors used to derive QSAR.
Public property | YValue | Measured values of QSAR.
Top
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData.CasNumber Property

ChemicalWithDataCasNumber Property

The chemical's Chemical Abstracts Service registry number.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int CasNumber { get; }

Property Value

Type: Int32
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData.ChemicalNames Property

ChemicalWithDataChemicalNames Property

The list of names for the chemical.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<string> ChemicalNames { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData.Smiles Property

ChemicalWithDataSmiles Property

SMILES representation of the chemical's structure.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Smiles { get; }

Property Value

Type: String
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData.XValues Property

ChemicalWithDataXValues Property

Values of X descriptors used to derive QSAR.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDescribedData[] XValues { get; }

Property Value

Type: TbDescribedData
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData.YValue Property

ChemicalWithDataYValue Property

Measured values of QSAR.

Namespace: Toolbox.Docking.Api.Chemical
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDescribedData YValue { get; }

Property Value

Type: TbDescribedData
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


ChemicalWithData Methods

The ChemicalWithData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChemicalWithData Class
Toolbox.Docking.Api.Chemical Namespace


Toolbox.Docking.Api.Control Namespace

Interfaces
 | Interface | Description
Public interface | ITbBasket | Combines work task and Chemical into an unit of work.
Public interface | ITbCalcService | This provides docked modules with access to Toolbox services.
Public interface | ITbCancellationToken | Wrapper for CancellationToken
Public interface | ITbInitTask | Provides basic workflow control as well as access to Toolbox services.
Public interface | ITbObjectCatalog | Provides access to information for all registered objects. Used in initialization functions to validate presence of required cross-used objects.
Public interface | ITbWorkTask | ITbWorkTask provides workflow control as well as access to Toolbox services.


ITbBasket Interface

Combines work task and Chemical into an unit of work.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbBasket

The ITbBasket type exposes the following members.

Properties
 | Name | Description
Public property | Chemical | Chemical to work on.
Public property | TargetChemical | Chemical which is defined as target in TB workflow. This is used in operations which execution on "Chemical" is in respect to "TargetChemical". (for example it is used in Structural similarity) Equals to WorkTask.TargetChemical, or explicitly defined target structure
Public property | WorkTask | Currently executed task. To be used for progress control. It also provides access to Toolbox services via the ITbWorkTask's CalcService .
Top
Methods
 | Name | Description
Public method | SubBasket(Chemical) | Return new basket task for different work chemical.
Public method | SubBasket(Chemical, Chemical) | Return new basket task for different work chemical with explicitly defined target chemical.
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbBasket Properties

The ITbBasket type exposes the following members.

Properties
 | Name | Description
Public property | Chemical | Chemical to work on.
Public property | TargetChemical | Chemical which is defined as target in TB workflow. This is used in operations which execution on "Chemical" is in respect to "TargetChemical". (for example it is used in Structural similarity) Equals to WorkTask.TargetChemical, or explicitly defined target structure
Public property | WorkTask | Currently executed task. To be used for progress control. It also provides access to Toolbox services via the ITbWorkTask's CalcService .
Top
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket.Chemical Property

ITbBasketChemical Property

Chemical to work on.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Chemical Chemical { get; }

Property Value

Type: Chemical
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket.TargetChemical Property

ITbBasketTargetChemical Property

Chemical which is defined as target in TB workflow. This is used in operations which execution on "Chemical" is in respect to "TargetChemical". (for example it is used in Structural similarity) Equals to WorkTask.TargetChemical, or explicitly defined target structure

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Chemical TargetChemical { get; }

Property Value

Type: Chemical
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket.WorkTask Property

ITbBasketWorkTask Property

Currently executed task. To be used for progress control. It also provides access to Toolbox services via the ITbWorkTask's CalcService .

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbWorkTask WorkTask { get; }

Property Value

Type: ITbWorkTask
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket Methods

Methods
 | Name | Description
Public method | SubBasket(Chemical) | Return new basket task for different work chemical.
Public method | SubBasket(Chemical, Chemical) | Return new basket task for different work chemical with explicitly defined target chemical.
Top
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket.SubBasket Method

ITbBasketSubBasket Method

Overload List
 | Name | Description
Public method | SubBasket(Chemical) | Return new basket task for different work chemical.
Public method | SubBasket(Chemical, Chemical) | Return new basket task for different work chemical with explicitly defined target chemical.
Top
See Also

Reference

ITbBasket Interface
Toolbox.Docking.Api.Control Namespace


ITbBasket.SubBasket Method (Chemical)

ITbBasketSubBasket Method (Chemical)

Return new basket task for different work chemical.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbBasket SubBasket(
    Chemical newWorkChem
)

Parameters

newWorkChem
Type: Toolbox.Docking.Api.ChemicalChemical
Chemical for which the sub-basket should be created.

Return Value

Type: ITbBasket
Resulting Toolbox basket.
See Also

Reference

ITbBasket Interface
SubBasket Overload
Toolbox.Docking.Api.Control Namespace


ITbBasket.SubBasket Method (Chemical, Chemical)

ITbBasketSubBasket Method (Chemical, Chemical)

Return new basket task for different work chemical with explicitly defined target chemical.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbBasket SubBasket(
    Chemical newWorkChem,
    Chemical explicitTargetChem
)

Parameters

newWorkChem
Type: Toolbox.Docking.Api.ChemicalChemical
Chemical for which the sub-basket should be created.
explicitTargetChem
Type: Toolbox.Docking.Api.ChemicalChemical
Defines target chemical

Return Value

Type: ITbBasket
Resulting Toolbox basket.
See Also

Reference

ITbBasket Interface
SubBasket Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService Interface

This provides docked modules with access to Toolbox services.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbCalcService : ITbObjectCatalog

The ITbCalcService type exposes the following members.

Properties
 | Name | Description
Public property | Calculators | QSAR Toolbox Calculators. (Inherited from ITbObjectCatalog.)
Public property | Metabolisms | QSAR Toolbox Metabolisms. (Inherited from ITbObjectCatalog.)
Public property | Profilers | QSAR Toolbox Profilers. (Inherited from ITbObjectCatalog.)
Public property | Qsars | QSAR Toolbox QSARs (Inherited from ITbObjectCatalog.)
Public property | ServerMode | Returns the ServerMode the objects in the catalog operate in. (Inherited from ITbObjectCatalog.)
Public property | StereoMode | Indicates what mode the ITbCalcService operates in.
Top
Methods
 | Name | Description
Public method | CalculateParameter(TbObjectId, String, ITbBasket) | Calculates a parameter value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateParameter(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates parameter values for a list of Chemicals.
Public method | CalculateQsar(TbObjectId, String, ITbBasket) | Calculates a QSAR prediction value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateQsar(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates QSAR prediction values for a list of Chemicals.
Public method | CheckDomain(TbObjectId, ITbBasket) | Predict domain of a target chemical. If specified object not implements ITbDomainProvider the result is TbDomainStatus.Undefined
Public method | CheckDomain(TbObjectId, ITbWorkTask, IReadOnlyListChemical) | Predict domain of a list of chemicals. If specified object not implements ITbDomainProvider the results are TbDomainStatus.Undefined
Public method | ConvertData | Convert a TbScalarData or TbData value from it's unit to a new unit. Chemical is provided because some conversions required Molecular weight (Inherited from ITbObjectCatalog.)
Public method | DefaultOptions | Provide access to DefaultOptions of another object. (Inherited from ITbObjectCatalog.)
Public method | ExecuteExtraAction | Execute an extra action of another object. Can be used when one object wrap another to re-address execution to wrapped object. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null
Public method | GetAbout | Provides About information for a particular Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetAllScales | Return a list with all registered in the system scales. (Inherited from ITbObjectCatalog.)
Public method | GetCalculatorInfo | Provides calculator's info for a Calculator Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetCategoriesOf(TbObjectId, String, ITbBasket) | Return the list of categories a Toolbox.Docking.Api.Chemical for a given Profiler
Public method | GetCategoriesOf(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Return the list of categories for a Toolbox.Docking.Api.Chemical list for a given Profiler
Public method | GetClientOptionsModule | Provide access to client options module of another object. (Inherited from ITbObjectCatalog.)
Public method | GetCurrentOptions | Return the current options of an object. If object has no options will return null. The obtained options can be used as parameter for any other service call. All service calls which requires options can be called with null in which case the default options for the object will be used. The purpose of this function is to store current options for later usages
Public method | GetExtraActions | Provide extra actions of other objects. Can be used if one object wrap another or for object-object communication. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null (Inherited from ITbObjectCatalog.)
Public method | GetMetabolismInfo | Provides metabolism's info for a Metabolism Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetMetabolites(TbObjectId, String, ITbBasket) | Metabolizes a Toolbox.Docking.Api.Chemical using a Toolbox Metabolizer object.
Public method | GetMetabolites(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Metabolizes a list of Chemicals using a Toolbox Metabolizer object.
Public method | GetProfilerInfo | Provides profiler's info for a Profiler Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetQsarInfo | Provides QSAR's info for a QSAR Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | UnifySmiles | Prepares a canonized version of a SMILES that may be of an unknown origin. (Inherited from ITbObjectCatalog.)
Public method | UnifyToKekuleSmiles | Prepares a kekule canonized version of a SMILES that may be of an unknown origin. (Inherited from ITbObjectCatalog.)
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbCalcService Properties

The ITbCalcService type exposes the following members.

Properties
 | Name | Description
Public property | Calculators | QSAR Toolbox Calculators. (Inherited from ITbObjectCatalog.)
Public property | Metabolisms | QSAR Toolbox Metabolisms. (Inherited from ITbObjectCatalog.)
Public property | Profilers | QSAR Toolbox Profilers. (Inherited from ITbObjectCatalog.)
Public property | Qsars | QSAR Toolbox QSARs (Inherited from ITbObjectCatalog.)
Public property | ServerMode | Returns the ServerMode the objects in the catalog operate in. (Inherited from ITbObjectCatalog.)
Public property | StereoMode | Indicates what mode the ITbCalcService operates in.
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.StereoMode Property

ITbCalcServiceStereoMode Property

Indicates what mode the ITbCalcService operates in.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool StereoMode { get; }

Property Value

Type: Boolean
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService Methods

The ITbCalcService type exposes the following members.

Methods
 | Name | Description
Public method | CalculateParameter(TbObjectId, String, ITbBasket) | Calculates a parameter value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateParameter(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates parameter values for a list of Chemicals.
Public method | CalculateQsar(TbObjectId, String, ITbBasket) | Calculates a QSAR prediction value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateQsar(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates QSAR prediction values for a list of Chemicals.
Public method | CheckDomain(TbObjectId, ITbBasket) | Predict domain of a target chemical. If specified object not implements ITbDomainProvider the result is TbDomainStatus.Undefined
Public method | CheckDomain(TbObjectId, ITbWorkTask, IReadOnlyListChemical) | Predict domain of a list of chemicals. If specified object not implements ITbDomainProvider the results are TbDomainStatus.Undefined
Public method | ConvertData | Convert a TbScalarData or TbData value from it's unit to a new unit. Chemical is provided because some conversions required Molecular weight (Inherited from ITbObjectCatalog.)
Public method | DefaultOptions | Provide access to DefaultOptions of another object. (Inherited from ITbObjectCatalog.)
Public method | ExecuteExtraAction | Execute an extra action of another object. Can be used when one object wrap another to re-address execution to wrapped object. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null
Public method | GetAbout | Provides About information for a particular Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetAllScales | Return a list with all registered in the system scales. (Inherited from ITbObjectCatalog.)
Public method | GetCalculatorInfo | Provides calculator's info for a Calculator Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetCategoriesOf(TbObjectId, String, ITbBasket) | Return the list of categories a Toolbox.Docking.Api.Chemical for a given Profiler
Public method | GetCategoriesOf(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Return the list of categories for a Toolbox.Docking.Api.Chemical list for a given Profiler
Public method | GetClientOptionsModule | Provide access to client options module of another object. (Inherited from ITbObjectCatalog.)
Public method | GetCurrentOptions | Return the current options of an object. If object has no options will return null. The obtained options can be used as parameter for any other service call. All service calls which requires options can be called with null in which case the default options for the object will be used. The purpose of this function is to store current options for later usages
Public method | GetExtraActions | Provide extra actions of other objects. Can be used if one object wrap another or for object-object communication. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null (Inherited from ITbObjectCatalog.)
Public method | GetMetabolismInfo | Provides metabolism's info for a Metabolism Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetMetabolites(TbObjectId, String, ITbBasket) | Metabolizes a Toolbox.Docking.Api.Chemical using a Toolbox Metabolizer object.
Public method | GetMetabolites(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Metabolizes a list of Chemicals using a Toolbox Metabolizer object.
Public method | GetProfilerInfo | Provides profiler's info for a Profiler Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | GetQsarInfo | Provides QSAR's info for a QSAR Toolbox object. (Inherited from ITbObjectCatalog.)
Public method | UnifySmiles | Prepares a canonized version of a SMILES that may be of an unknown origin. (Inherited from ITbObjectCatalog.)
Public method | UnifyToKekuleSmiles | Prepares a kekule canonized version of a SMILES that may be of an unknown origin. (Inherited from ITbObjectCatalog.)
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateParameter Method

ITbCalcServiceCalculateParameter Method

Overload List
 | Name | Description
Public method | CalculateParameter(TbObjectId, String, ITbBasket) | Calculates a parameter value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateParameter(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates parameter values for a list of Chemicals.
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateParameter Method (TbObjectId, String, ITbBasket)

ITbCalcServiceCalculateParameter Method (TbObjectId, String, ITbBasket)

Calculates a parameter value for a Toolbox.Docking.Api.Chemical.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScalarData CalculateParameter(
    TbObjectId calculatorId,
    string options,
    ITbBasket target
)

Parameters

calculatorId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the calculator performing the calculation.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
target
Type: Toolbox.Docking.Api.ControlITbBasket
The target basket, containing the Toolbox.Docking.Api.Chemical.

Return Value

Type: TbScalarData
Resulting TbScalarData object with the calculation.
See Also

Reference

ITbCalcService Interface
CalculateParameter Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateParameter Method (TbObjectId, String, ITbWorkTask, IReadOnlyList(Chemical))

ITbCalcServiceCalculateParameter Method (TbObjectId, String, ITbWorkTask, IReadOnlyListChemical)

Calculates parameter values for a list of Chemicals.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbScalarData> CalculateParameter(
    TbObjectId calculatorId,
    string options,
    ITbWorkTask task,
    IReadOnlyList<Chemical> targets
)

Parameters

calculatorId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the calculator performing the calculation.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task governing the calculation. This is to be used for progress updates and/or access to Toolbox services.
targets
Type: System.Collections.GenericIReadOnlyList Chemical
The list chemicals for calculations.

Return Value

Type: IReadOnlyList TbScalarData
The list with calculation results, corresponding to target list.
See Also

Reference

ITbCalcService Interface
CalculateParameter Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateQsar Method

ITbCalcServiceCalculateQsar Method

Overload List
 | Name | Description
Public method | CalculateQsar(TbObjectId, String, ITbBasket) | Calculates a QSAR prediction value for a Toolbox.Docking.Api.Chemical.
Public method | CalculateQsar(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Calculates QSAR prediction values for a list of Chemicals.
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateQsar Method (TbObjectId, String, ITbBasket)

ITbCalcServiceCalculateQsar Method (TbObjectId, String, ITbBasket)

Calculates a QSAR prediction value for a Toolbox.Docking.Api.Chemical.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScalarData CalculateQsar(
    TbObjectId qsarId,
    string options,
    ITbBasket target
)

Parameters

qsarId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the QSAR performing the calculation.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
target
Type: Toolbox.Docking.Api.ControlITbBasket
The target basket, containing the Toolbox.Docking.Api.Chemical

Return Value

Type: TbScalarData
Resulting TbScalarData object with the QSAR prediction.
See Also

Reference

ITbCalcService Interface
CalculateQsar Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CalculateQsar Method (TbObjectId, String, ITbWorkTask, IReadOnlyList(Chemical))

ITbCalcServiceCalculateQsar Method (TbObjectId, String, ITbWorkTask, IReadOnlyListChemical)

Calculates QSAR prediction values for a list of Chemicals.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbScalarData> CalculateQsar(
    TbObjectId qsarId,
    string options,
    ITbWorkTask task,
    IReadOnlyList<Chemical> targets
)

Parameters

qsarId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the QSAR performing the calculation.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task governing the calculation. This is to be used for progress updates and/or access to Toolbox services.
targets
Type: System.Collections.GenericIReadOnlyList Chemical
The list of chemicals for calculations.

Return Value

Type: IReadOnlyList TbScalarData
The list with prediction results, corresponding to target list.
See Also

Reference

ITbCalcService Interface
CalculateQsar Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CheckDomain Method

ITbCalcServiceCheckDomain Method

Overload List
 | Name | Description
Public method | CheckDomain(TbObjectId, ITbBasket) | Predict domain of a target chemical. If specified object not implements ITbDomainProvider the result is TbDomainStatus.Undefined
Public method | CheckDomain(TbObjectId, ITbWorkTask, IReadOnlyListChemical) | Predict domain of a list of chemicals. If specified object not implements ITbDomainProvider the results are TbDomainStatus.Undefined
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CheckDomain Method (TbObjectId, ITbBasket)

ITbCalcServiceCheckDomain Method (TbObjectId, ITbBasket)

Predict domain of a target chemical. If specified object not implements ITbDomainProvider the result is TbDomainStatus.Undefined

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbDomainStatus CheckDomain(
    TbObjectId objectId,
    ITbBasket target
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
Identifier of the Toolbox object that will perform the check
target
Type: Toolbox.Docking.Api.ControlITbBasket
Target chemical for the domain check.

Return Value

Type: TbDomainStatus
Domain status result.
See Also

Reference

ITbCalcService Interface
CheckDomain Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.CheckDomain Method (TbObjectId, ITbWorkTask, IReadOnlyList(Chemical))

ITbCalcServiceCheckDomain Method (TbObjectId, ITbWorkTask, IReadOnlyListChemical)

Predict domain of a list of chemicals. If specified object not implements ITbDomainProvider the results are TbDomainStatus.Undefined

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbDomainStatus> CheckDomain(
    TbObjectId objectId,
    ITbWorkTask task,
    IReadOnlyList<Chemical> targets
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
Identifier of the Toolbox object that will perform the check
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task to be used for notifications and flow control.
targets
Type: System.Collections.GenericIReadOnlyList Chemical
The target chemicals

Return Value

Type: IReadOnlyList TbDomainStatus
Domain status result.
See Also

Reference

ITbCalcService Interface
CheckDomain Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.ExecuteExtraAction Method

ITbCalcServiceExecuteExtraAction Method

Execute an extra action of another object. Can be used when one object wrap another to re-address execution to wrapped object. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbExtraActionResult ExecuteExtraAction(
    TbObjectId objectId,
    Guid action,
    int command,
    string payload,
    ITbBasket target
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
Toolbox object id that will be executing the action.
action
Type: SystemGuid
GUID of the actuion.
command
Type: SystemInt32
Integer code of the executed command.
payload
Type: SystemString
Payload encoded as string that will be transported from to/from the client/server side modules of the Toolbox addin.
target
Type: Toolbox.Docking.Api.ControlITbBasket
Target chemical the Toolbox action would be performed over.

Return Value

Type: TbExtraActionResult
The extra action's result
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetCategoriesOf Method

ITbCalcServiceGetCategoriesOf Method

Overload List
 | Name | Description
Public method | GetCategoriesOf(TbObjectId, String, ITbBasket) | Return the list of categories a Toolbox.Docking.Api.Chemical for a given Profiler
Public method | GetCategoriesOf(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Return the list of categories for a Toolbox.Docking.Api.Chemical list for a given Profiler
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetCategoriesOf Method (TbObjectId, String, ITbBasket)

ITbCalcServiceGetCategoriesOf Method (TbObjectId, String, ITbBasket)

Return the list of categories a Toolbox.Docking.Api.Chemical for a given Profiler

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<string> GetCategoriesOf(
    TbObjectId profilerId,
    string options,
    ITbBasket target
)

Parameters

profilerId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the Profiler
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
target
Type: Toolbox.Docking.Api.ControlITbBasket
The target basket, containing the Toolbox.Docking.Api.Chemical

Return Value

Type: IReadOnlyList String
Resulting list of categories for the profiled chemical.
See Also

Reference

ITbCalcService Interface
GetCategoriesOf Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetCategoriesOf Method (TbObjectId, String, ITbWorkTask, IReadOnlyList(Chemical))

ITbCalcServiceGetCategoriesOf Method (TbObjectId, String, ITbWorkTask, IReadOnlyListChemical)

Return the list of categories for a Toolbox.Docking.Api.Chemical list for a given Profiler

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<IReadOnlyList<string>> GetCategoriesOf(
    TbObjectId profilerId,
    string options,
    ITbWorkTask task,
    IReadOnlyList<Chemical> targets
)

Parameters

profilerId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the Profiler
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task governing the Profiler application. This is to be used for progress updates and/or access to Toolbox services.
targets
Type: System.Collections.GenericIReadOnlyList Chemical
The list chemicals up for Profiler assessment

Return Value

Type: IReadOnlyList IReadOnlyList String
Resulting list of lists of categories for the profiled chemicals.
See Also

Reference

ITbCalcService Interface
GetCategoriesOf Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetCurrentOptions Method

ITbCalcServiceGetCurrentOptions Method

Return the current options of an object. If object has no options will return null. The obtained options can be used as parameter for any other service call. All service calls which requires options can be called with null in which case the default options for the object will be used. The purpose of this function is to store current options for later usages

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetCurrentOptions(
    TbObjectId objectId,
    ITbWorkTask task
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task to be used for notifications and flow control.

Return Value

Type: String
The Toolbox options encoded to string.
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetMetabolites Method

ITbCalcServiceGetMetabolites Method

Overload List
 | Name | Description
Public method | GetMetabolites(TbObjectId, String, ITbBasket) | Metabolizes a Toolbox.Docking.Api.Chemical using a Toolbox Metabolizer object.
Public method | GetMetabolites(TbObjectId, String, ITbWorkTask, IReadOnlyListChemical) | Metabolizes a list of Chemicals using a Toolbox Metabolizer object.
Top
See Also

Reference

ITbCalcService Interface
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetMetabolites Method (TbObjectId, String, ITbBasket)

ITbCalcServiceGetMetabolites Method (TbObjectId, String, ITbBasket)

Metabolizes a Toolbox.Docking.Api.Chemical using a Toolbox Metabolizer object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<Chemical> GetMetabolites(
    TbObjectId metabolizerId,
    string options,
    ITbBasket target
)

Parameters

metabolizerId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the Toolbox object metabolizing the chemical.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
target
Type: Toolbox.Docking.Api.ControlITbBasket
The target basket, containing the Toolbox.Docking.Api.Chemical.

Return Value

Type: IReadOnlyList Chemical
Resulting list of Chemicals(products)
See Also

Reference

ITbCalcService Interface
GetMetabolites Overload
Toolbox.Docking.Api.Control Namespace


ITbCalcService.GetMetabolites Method (TbObjectId, String, ITbWorkTask, IReadOnlyList(Chemical))

ITbCalcServiceGetMetabolites Method (TbObjectId, String, ITbWorkTask, IReadOnlyListChemical)

Metabolizes a list of Chemicals using a Toolbox Metabolizer object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<IReadOnlyList<Chemical>> GetMetabolites(
    TbObjectId metabolizerId,
    string options,
    ITbWorkTask task,
    IReadOnlyList<Chemical> targets
)

Parameters

metabolizerId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox ID of the Toolbox object performing the metabolization the chemicals.
options
Type: SystemString
Options for the calculation. Use string.Empty if no options are needed.
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task governing the calculation. This is to be used for progress updates and/or access to Toolbox services.
targets
Type: System.Collections.GenericIReadOnlyList Chemical
The list of chemicals to be metabolized.

Return Value

Type: IReadOnlyList IReadOnlyList Chemical
The list with metabolism results(list of products), corresponding to target list.
See Also

Reference

ITbCalcService Interface
GetMetabolites Overload
Toolbox.Docking.Api.Control Namespace


ITbCancellationToken Interface

Wrapper for CancellationToken

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbCancellationToken

The ITbCancellationToken type exposes the following members.

Properties
 | Name | Description
Public property | IsCancellationRequested | Gets whether cancellation has been requested for this token
Top
Methods
 | Name | Description
Public method | ThrowIfCancellationRequested | Throws a OperationCanceledException if this token has had cancellation requested.
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbCancellationToken Properties

The ITbCancellationToken type exposes the following members.

Properties
 | Name | Description
Public property | IsCancellationRequested | Gets whether cancellation has been requested for this token
Top
See Also

Reference

ITbCancellationToken Interface
Toolbox.Docking.Api.Control Namespace


ITbCancellationToken.IsCancellationRequested Property

ITbCancellationTokenIsCancellationRequested Property

Gets whether cancellation has been requested for this token

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsCancellationRequested { get; }

Property Value

Type: Boolean
See Also

Reference

ITbCancellationToken Interface
Toolbox.Docking.Api.Control Namespace


ITbCancellationToken Methods

The ITbCancellationToken type exposes the following members.

Methods
 | Name | Description
Public method | ThrowIfCancellationRequested | Throws a OperationCanceledException if this token has had cancellation requested.
Top
See Also

Reference

ITbCancellationToken Interface
Toolbox.Docking.Api.Control Namespace


ITbCancellationToken.ThrowIfCancellationRequested Method

ITbCancellationTokenThrowIfCancellationRequested Method

Throws a OperationCanceledException if this token has had cancellation requested.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ThrowIfCancellationRequested()
See Also

Reference

ITbCancellationToken Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask Interface

Provides basic workflow control as well as access to Toolbox services.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbInitTask : IDisposable

The ITbInitTask type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption for the Task. This is used for UI purposes.
Public property | MaxProgress | Upper bound for progress.
Public property | MeaningfulProgress | Returns whether the progress is a meaningful one or an indefinite(rolling) type.
Public property | ObjectCatalog | A catalog of available Toolbox objects and services.
Public property | ProgressLevel | Current progress position.
Public property | StartedAt | Time stamp for the task start.
Public property | Status | Status for the Task. This is used for UI purposes.
Public property | TbToken | Flow control token.
Top
Methods
 | Name | Description
Public method | CreateSubTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LogException | Log exceptions that might have been thrown during a task's execution.
Public method | WorkItemDone | Call this to signify that an item is done and to update the task progress (increment ProgressLevel).
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbInitTask Properties

The ITbInitTask type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption for the Task. This is used for UI purposes.
Public property | MaxProgress | Upper bound for progress.
Public property | MeaningfulProgress | Returns whether the progress is a meaningful one or an indefinite(rolling) type.
Public property | ObjectCatalog | A catalog of available Toolbox objects and services.
Public property | ProgressLevel | Current progress position.
Public property | StartedAt | Time stamp for the task start.
Public property | Status | Status for the Task. This is used for UI purposes.
Public property | TbToken | Flow control token.
Top
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.Caption Property

ITbInitTaskCaption Property

Caption for the Task. This is used for UI purposes.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Caption { get; }

Property Value

Type: String
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.MaxProgress Property

ITbInitTaskMaxProgress Property

Upper bound for progress.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
int MaxProgress { get; }

Property Value

Type: Int32
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.MeaningfulProgress Property

ITbInitTaskMeaningfulProgress Property

Returns whether the progress is a meaningful one or an indefinite(rolling) type.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool MeaningfulProgress { get; }

Property Value

Type: Boolean
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.ObjectCatalog Property

ITbInitTaskObjectCatalog Property

A catalog of available Toolbox objects and services.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbObjectCatalog ObjectCatalog { get; }

Property Value

Type: ITbObjectCatalog
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.ProgressLevel Property

ITbInitTaskProgressLevel Property

Current progress position.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
int ProgressLevel { get; }

Property Value

Type: Int32
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.StartedAt Property

ITbInitTaskStartedAt Property

Time stamp for the task start.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
DateTime StartedAt { get; }

Property Value

Type: DateTime
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.Status Property

ITbInitTaskStatus Property

Status for the Task. This is used for UI purposes.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Status { get; set; }

Property Value

Type: String
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.TbToken Property

ITbInitTaskTbToken Property

Flow control token.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbCancellationToken TbToken { get; }

Property Value

Type: ITbCancellationToken
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask Methods

The ITbInitTask type exposes the following members.

Methods
 | Name | Description
Public method | CreateSubTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LogException | Log exceptions that might have been thrown during a task's execution.
Public method | WorkItemDone | Call this to signify that an item is done and to update the task progress (increment ProgressLevel).
Top
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.CreateSubTask Method

ITbInitTaskCreateSubTask Method

Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbInitTask CreateSubTask(
    string subTaskCaption,
    int subTaskMaxProgress,
    bool meaningfulProgress
)

Parameters

subTaskCaption
Type: SystemString
The caption for the sub-task.
subTaskMaxProgress
Type: SystemInt32
The number of items for the task.
meaningfulProgress
Type: SystemBoolean
Specify whether this will be a meaningful progress or an infinite progress.

Return Value

Type: ITbInitTask
The resulting sub-task.
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.LogException Method

ITbInitTaskLogException Method

Log exceptions that might have been thrown during a task's execution.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void LogException(
    Exception exception
)

Parameters

exception
Type: SystemException
The logged exception.
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbInitTask.WorkItemDone Method

ITbInitTaskWorkItemDone Method

Call this to signify that an item is done and to update the task progress (increment ProgressLevel).

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void WorkItemDone()
See Also

Reference

ITbInitTask Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog Interface

Provides access to information for all registered objects. Used in initialization functions to validate presence of required cross-used objects.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectCatalog

The ITbObjectCatalog type exposes the following members.

Properties
 | Name | Description
Public property | Calculators | QSAR Toolbox Calculators.
Public property | Metabolisms | QSAR Toolbox Metabolisms.
Public property | Profilers | QSAR Toolbox Profilers.
Public property | Qsars | QSAR Toolbox QSARs
Public property | ServerMode | Returns the ServerMode the objects in the catalog operate in.
Top
Methods
 | Name | Description
Public method | ConvertData | Convert a TbScalarData or TbData value from it's unit to a new unit. Chemical is provided because some conversions required Molecular weight
Public method | DefaultOptions | Provide access to DefaultOptions of another object.
Public method | GetAbout | Provides About information for a particular Toolbox object.
Public method | GetAllScales | Return a list with all registered in the system scales.
Public method | GetCalculatorInfo | Provides calculator's info for a Calculator Toolbox object.
Public method | GetClientOptionsModule | Provide access to client options module of another object.
Public method | GetExtraActions | Provide extra actions of other objects. Can be used if one object wrap another or for object-object communication. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null
Public method | GetMetabolismInfo | Provides metabolism's info for a Metabolism Toolbox object.
Public method | GetProfilerInfo | Provides profiler's info for a Profiler Toolbox object.
Public method | GetQsarInfo | Provides QSAR's info for a QSAR Toolbox object.
Public method | UnifySmiles | Prepares a canonized version of a SMILES that may be of an unknown origin.
Public method | UnifyToKekuleSmiles | Prepares a kekule canonized version of a SMILES that may be of an unknown origin.
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog Properties

The ITbObjectCatalog type exposes the following members.

Properties
 | Name | Description
Public property | Calculators | QSAR Toolbox Calculators.
Public property | Metabolisms | QSAR Toolbox Metabolisms.
Public property | Profilers | QSAR Toolbox Profilers.
Public property | Qsars | QSAR Toolbox QSARs
Public property | ServerMode | Returns the ServerMode the objects in the catalog operate in.
Top
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.Calculators Property

ITbObjectCatalogCalculators Property

QSAR Toolbox Calculators.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbObjectId> Calculators { get; }

Property Value

Type: IReadOnlyList TbObjectId
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.Metabolisms Property

ITbObjectCatalogMetabolisms Property

QSAR Toolbox Metabolisms.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbObjectId> Metabolisms { get; }

Property Value

Type: IReadOnlyList TbObjectId
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.Profilers Property

ITbObjectCatalogProfilers Property

QSAR Toolbox Profilers.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbObjectId> Profilers { get; }

Property Value

Type: IReadOnlyList TbObjectId
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.Qsars Property

ITbObjectCatalogQsars Property

QSAR Toolbox QSARs

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<TbObjectId> Qsars { get; }

Property Value

Type: IReadOnlyList TbObjectId
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.ServerMode Property

ITbObjectCatalogServerMode Property

Returns the ServerMode the objects in the catalog operate in.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbServerMode ServerMode { get; }

Property Value

Type: TbServerMode
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog Methods

The ITbObjectCatalog type exposes the following members.

Methods
 | Name | Description
Public method | ConvertData | Convert a TbScalarData or TbData value from it's unit to a new unit. Chemical is provided because some conversions required Molecular weight
Public method | DefaultOptions | Provide access to DefaultOptions of another object.
Public method | GetAbout | Provides About information for a particular Toolbox object.
Public method | GetAllScales | Return a list with all registered in the system scales.
Public method | GetCalculatorInfo | Provides calculator's info for a Calculator Toolbox object.
Public method | GetClientOptionsModule | Provide access to client options module of another object.
Public method | GetExtraActions | Provide extra actions of other objects. Can be used if one object wrap another or for object-object communication. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null
Public method | GetMetabolismInfo | Provides metabolism's info for a Metabolism Toolbox object.
Public method | GetProfilerInfo | Provides profiler's info for a Profiler Toolbox object.
Public method | GetQsarInfo | Provides QSAR's info for a QSAR Toolbox object.
Public method | UnifySmiles | Prepares a canonized version of a SMILES that may be of an unknown origin.
Public method | UnifyToKekuleSmiles | Prepares a kekule canonized version of a SMILES that may be of an unknown origin.
Top
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.ConvertData Method

ITbObjectCatalogConvertData Method

Convert a TbScalarData or TbData value from it's unit to a new unit. Chemical is provided because some conversions required Molecular weight

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScalarData ConvertData(
    TbScalarData data,
    TbUnit toUnit,
    Chemical chemical
)

Parameters

data
Type: Toolbox.Docking.Api.DataTbScalarData
Data to be converted
toUnit
Type: Toolbox.Docking.Api.UnitsTbUnit
Target unit of conversion
chemical
Type: Toolbox.Docking.Api.ChemicalChemical
Chemical related with converted data

Return Value

Type: TbScalarData
The prepared scalar data object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.DefaultOptions Method

ITbObjectCatalogDefaultOptions Method

Provide access to DefaultOptions of another object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string DefaultOptions(
    TbObjectId objectId,
    ITbWorkTask task
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.
task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task to be used for notifications and flow control.

Return Value

Type: String
Return DefaultOptions if objectId correspond to ITbObjectFactoryTunable, otherwise return null
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetAbout Method

ITbObjectCatalogGetAbout Method

Provides About information for a particular Toolbox object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbObjectAbout GetAbout(
    TbObjectId id
)

Parameters

id
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.

Return Value

Type: TbObjectAbout
About object for the Toolbox object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetAllScales Method

ITbObjectCatalogGetAllScales Method

Return a list with all registered in the system scales.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IEnumerable<TbScale> GetAllScales()

Return Value

Type: IEnumerable TbScale
List of Toolbox scales.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetCalculatorInfo Method

ITbObjectCatalogGetCalculatorInfo Method

Provides calculator's info for a Calculator Toolbox object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbCalculatorInfo GetCalculatorInfo(
    TbObjectId id,
    ITbInitTask initTask
)

Parameters

id
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.
initTask
Type: Toolbox.Docking.Api.ControlITbInitTask
This is required parameter because the call may trigger object initialization

Return Value

Type: TbCalculatorInfo
Calculator information object for the Toolbox object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetClientOptionsModule Method

ITbObjectCatalogGetClientOptionsModule Method

Provide access to client options module of another object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetClientOptionsModule(
    TbObjectId objectId
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.

Return Value

Type: String
Return ClientOptionsModule if objectId correspond to ITbObjectFactoryTunable, otherwise return null
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetExtraActions Method

ITbObjectCatalogGetExtraActions Method

Provide extra actions of other objects. Can be used if one object wrap another or for object-object communication. If the queried object factory not implement ITbObjectFactoryExtraAction the result is null

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IEnumerable<TbExtraActionDefinition> GetExtraActions(
    TbObjectId objectId
)

Parameters

objectId
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The target object

Return Value

Type: IEnumerable TbExtraActionDefinition
List of extra actions.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetMetabolismInfo Method

ITbObjectCatalogGetMetabolismInfo Method

Provides metabolism's info for a Metabolism Toolbox object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbMetabolismInfo GetMetabolismInfo(
    TbObjectId id
)

Parameters

id
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.

Return Value

Type: TbMetabolismInfo
Metabolism information object for the Toolbox object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetProfilerInfo Method

ITbObjectCatalogGetProfilerInfo Method

Provides profiler's info for a Profiler Toolbox object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbProfilerInfo GetProfilerInfo(
    TbObjectId id
)

Parameters

id
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.

Return Value

Type: TbProfilerInfo
Profiler information object for the Toolbox object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.GetQsarInfo Method

ITbObjectCatalogGetQsarInfo Method

Provides QSAR's info for a QSAR Toolbox object.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbQsarInfo GetQsarInfo(
    TbObjectId id
)

Parameters

id
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object identifier.

Return Value

Type: TbQsarInfo
QSAR information object for the Toolbox object.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.UnifySmiles Method

ITbObjectCatalogUnifySmiles Method

Prepares a canonized version of a SMILES that may be of an unknown origin.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string UnifySmiles(
    string nonCanonicalSmiles
)

Parameters

nonCanonicalSmiles
Type: SystemString
Input SMILES.

Return Value

Type: String
Resulting canonical SMILES.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbObjectCatalog.UnifyToKekuleSmiles Method

ITbObjectCatalogUnifyToKekuleSmiles Method

Prepares a kekule canonized version of a SMILES that may be of an unknown origin.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string UnifyToKekuleSmiles(
    string nonCanonicalSmiles
)

Parameters

nonCanonicalSmiles
Type: SystemString
Input SMILES.

Return Value

Type: String
Resulting canonical SMILES.
See Also

Reference

ITbObjectCatalog Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask Interface

ITbWorkTask provides workflow control as well as access to Toolbox services.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbWorkTask : ITbInitTask,
    IDisposable

The ITbWorkTask type exposes the following members.

Properties
 | Name | Description
Public property | CalcService | Provides access to the Toolbox calculation service.
Public property | Caption | Caption for the Task. This is used for UI purposes. (Inherited from ITbInitTask.)
Public property | IsTimeOut | When IsTimeOut is true the Token.IsCancellationRequested is also true. Use this only when need to distinguish cancellation and cancellation due to time out.
Public property | MaxProgress | Upper bound for progress. (Inherited from ITbInitTask.)
Public property | MeaningfulProgress | Returns whether the progress is a meaningful one or an indefinite(rolling) type. (Inherited from ITbInitTask.)
Public property | ObjectCatalog | A catalog of available Toolbox objects and services. (Inherited from ITbInitTask.)
Public property | ProgressLevel | Current progress position. (Inherited from ITbInitTask.)
Public property | StartedAt | Time stamp for the task start. (Inherited from ITbInitTask.)
Public property | Status | Status for the Task. This is used for UI purposes. (Inherited from ITbInitTask.)
Public property | StereoMode | Specifies whether the work task operates with or without accounting of StereoMode.
Public property | TargetChemical | The chemical set as target for Toolbox workflow.
Public property | TbToken | Flow control token. (Inherited from ITbInitTask.)
Public property | UseCalculatorExternalCache | Specifies whether the task would use external calculator cache.
Top
Methods
 | Name | Description
Public method | CreateChemical(String, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Public method | CreateChemical(Int32, String, IEnumerableString, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Public method | CreateSubTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses. (Inherited from ITbInitTask.)
Public method | CreateSubWorkTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LogException | Log exceptions that might have been thrown during a task's execution. (Inherited from ITbInitTask.)
Public method | WorkItemDone | Call this to signify that an item is done and to update the task progress (increment ProgressLevel). (Inherited from ITbInitTask.)
Top
See Also

Reference

Toolbox.Docking.Api.Control Namespace


ITbWorkTask Properties

The ITbWorkTask type exposes the following members.

Properties
 | Name | Description
Public property | CalcService | Provides access to the Toolbox calculation service.
Public property | Caption | Caption for the Task. This is used for UI purposes. (Inherited from ITbInitTask.)
Public property | IsTimeOut | When IsTimeOut is true the Token.IsCancellationRequested is also true. Use this only when need to distinguish cancellation and cancellation due to time out.
Public property | MaxProgress | Upper bound for progress. (Inherited from ITbInitTask.)
Public property | MeaningfulProgress | Returns whether the progress is a meaningful one or an indefinite(rolling) type. (Inherited from ITbInitTask.)
Public property | ObjectCatalog | A catalog of available Toolbox objects and services. (Inherited from ITbInitTask.)
Public property | ProgressLevel | Current progress position. (Inherited from ITbInitTask.)
Public property | StartedAt | Time stamp for the task start. (Inherited from ITbInitTask.)
Public property | Status | Status for the Task. This is used for UI purposes. (Inherited from ITbInitTask.)
Public property | StereoMode | Specifies whether the work task operates with or without accounting of StereoMode.
Public property | TargetChemical | The chemical set as target for Toolbox workflow.
Public property | TbToken | Flow control token. (Inherited from ITbInitTask.)
Public property | UseCalculatorExternalCache | Specifies whether the task would use external calculator cache.
Top
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.CalcService Property

ITbWorkTaskCalcService Property

Provides access to the Toolbox calculation service.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbCalcService CalcService { get; }

Property Value

Type: ITbCalcService
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.IsTimeOut Property

ITbWorkTaskIsTimeOut Property

When IsTimeOut is true the Token.IsCancellationRequested is also true. Use this only when need to distinguish cancellation and cancellation due to time out.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsTimeOut { get; }

Property Value

Type: Boolean
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.StereoMode Property

ITbWorkTaskStereoMode Property

Specifies whether the work task operates with or without accounting of StereoMode.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool StereoMode { get; }

Property Value

Type: Boolean
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.TargetChemical Property

ITbWorkTaskTargetChemical Property

The chemical set as target for Toolbox workflow.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Chemical TargetChemical { get; }

Property Value

Type: Chemical
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.UseCalculatorExternalCache Property

ITbWorkTaskUseCalculatorExternalCache Property

Specifies whether the task would use external calculator cache.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool UseCalculatorExternalCache { get; }

Property Value

Type: Boolean
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask Methods

The ITbWorkTask type exposes the following members.

Methods
 | Name | Description
Public method | CreateChemical(String, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Public method | CreateChemical(Int32, String, IEnumerableString, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Public method | CreateSubTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses. (Inherited from ITbInitTask.)
Public method | CreateSubWorkTask | Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | LogException | Log exceptions that might have been thrown during a task's execution. (Inherited from ITbInitTask.)
Public method | WorkItemDone | Call this to signify that an item is done and to update the task progress (increment ProgressLevel). (Inherited from ITbInitTask.)
Top
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.CreateChemical Method

ITbWorkTaskCreateChemical Method

Overload List
 | Name | Description
Public method | CreateChemical(String, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Public method | CreateChemical(Int32, String, IEnumerableString, String) | Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.
Top
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.CreateChemical Method (String, String)

ITbWorkTaskCreateChemical Method (String, String)

Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Chemical CreateChemical(
    string nonCanonicSmiles,
    out string problem
)

Parameters

nonCanonicSmiles
Type: SystemString
External SMILES.
problem
Type: SystemString
Empty string in case of successfully recognized SMILES, otherwise contains the identified problem

Return Value

Type: Chemical
Constructed Toolbox.Docking.Api.Chemical object that can be used within the Toolbox workflow.
See Also

Reference

ITbWorkTask Interface
CreateChemical Overload
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.CreateChemical Method (Int32, String, IEnumerable(String), String)

ITbWorkTaskCreateChemical Method (Int32, String, IEnumerableString, String)

Creates a canonized Toolbox structure from a SMILES of a possibly unknown origin or SMILES dialect.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Chemical CreateChemical(
    int cas,
    string nonCanonicSmiles,
    IEnumerable<string> names,
    out string problem
)

Parameters

cas
Type: SystemInt32
The CAS number for the Toolbox.Docking.Api.Chemical.
nonCanonicSmiles
Type: SystemString
External SMILES.
names
Type: System.Collections.GenericIEnumerable String
The names for the Toolbox.Docking.Api.Chemical.
problem
Type: SystemString
Empty string in case of successfully recognized SMILES, otherwise contains the identified problem

Return Value

Type: Chemical
Constructed Toolbox.Docking.Api.Chemical object that can be used within the Toolbox workflow.
See Also

Reference

ITbWorkTask Interface
CreateChemical Overload
Toolbox.Docking.Api.Control Namespace


ITbWorkTask.CreateSubWorkTask Method

ITbWorkTaskCreateSubWorkTask Method

Creates a sub-task. Tasks should be broken down in smaller tasks in order to better inform the user how a task progresses.

Namespace: Toolbox.Docking.Api.Control
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbWorkTask CreateSubWorkTask(
    string subTaskCaption,
    int subTaskMaxProgress,
    bool meaningfulProgress
)

Parameters

subTaskCaption
Type: SystemString
The caption for the sub-task.
subTaskMaxProgress
Type: SystemInt32
The number of items for the task.
meaningfulProgress
Type: SystemBoolean
Specify whether this will be a meaningful progress or an infinite progress.

Return Value

Type: ITbWorkTask
The resulting work sub-task.
See Also

Reference

ITbWorkTask Interface
Toolbox.Docking.Api.Control Namespace


Toolbox.Docking.Api.Data Namespace

Classes
 | Class | Description
Public class | TbData | This class represents a Toolbox data value.
Public class | TbDescribedData | Toolbox data value with associated metadata
Public class | TbMetadata | Toolbox metadata object.
Public class | TbScalarData | Scalar data value definition object.
Enumerations
 | Enumeration | Description
Public enumeration | TbDataQualifier | Represents values qualifiers


TbData Class

This class represents a Toolbox data value.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.DataTbScalarData
Toolbox.Docking.Api.DataTbData

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbData : TbScalarData

The TbData type exposes the following members.

Constructors
 | Name | Description
Public method | TbData(TbScalarData) | Data constructor from TbScalarData.
Public method | TbData(TbUnit, NullableDouble) | Toolbox data value description object constructor.
Public method | TbData(TbUnit, NullableDouble, TbDataQualifier) | Toolbox data value description object constructor.
Public method | TbData(TbUnit, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier) | Toolbox data value description object constructor.
Top
Properties
 | Name | Description
Public property | MaxQualifier | Max value for the range.
Public property | MaxValue | Max value for the range.
Public property | MinQualifier | Min value qualifier.
Public property | MinValue | Min value for the range.
Public property | Qualifier | Value qualifier. (Inherited from TbScalarData.)
Public property | Unit | The unit of this data. (Inherited from TbScalarData.)
Public property | Value | The value of this data. (Inherited from TbScalarData.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Data Namespace


TbData Constructor

Overload List
 | Name | Description
Public method | TbData(TbScalarData) | Data constructor from TbScalarData.
Public method | TbData(TbUnit, NullableDouble) | Toolbox data value description object constructor.
Public method | TbData(TbUnit, NullableDouble, TbDataQualifier) | Toolbox data value description object constructor.
Public method | TbData(TbUnit, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier) | Toolbox data value description object constructor.
Top
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData Constructor (TbScalarData)

Data constructor from TbScalarData.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbData(
    TbScalarData scalarData
)

Parameters

scalarData
Type: Toolbox.Docking.Api.DataTbScalarData
Scalar to be copied from.
See Also

Reference

TbData Class
TbData Overload
Toolbox.Docking.Api.Data Namespace


TbData Constructor (TbUnit, Nullable(Double))

TbData Constructor (TbUnit, NullableDouble)

Toolbox data value description object constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbData(
    TbUnit unit,
    Nullable<double> value
)

Parameters

unit
Type: Toolbox.Docking.Api.UnitsTbUnit
The Toolbox unit for the data value.
value
Type: SystemNullable Double
The corresponding value. The value is nullable to account for the case when the unit contains the actual value i.e. contains a categorical data in its FamilyName (e.g. Mutagenicity) and Unit (e.g. Positive)
See Also

Reference

TbData Class
TbData Overload
Toolbox.Docking.Api.Data Namespace


TbData Constructor (TbUnit, Nullable(Double), TbDataQualifier)

TbData Constructor (TbUnit, NullableDouble, TbDataQualifier)

Toolbox data value description object constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbData(
    TbUnit unit,
    Nullable<double> value,
    TbDataQualifier qualifier
)

Parameters

unit
Type: Toolbox.Docking.Api.UnitsTbUnit
The Toolbox unit for the data value.
value
Type: SystemNullable Double
The corresponding value. The value is nullable to account for the case when the unit contains the actual value i.e. contains a categorical data in its FamilyName (e.g. Mutagenicity) and Unit (e.g. Positive).
qualifier
Type: Toolbox.Docking.Api.DataTbDataQualifier
Qualifier for the value.
See Also

Reference

TbData Class
TbData Overload
Toolbox.Docking.Api.Data Namespace


TbData Constructor (TbUnit, Nullable(Double), TbDataQualifier, Nullable(Double), TbDataQualifier, Nullable(Double), TbDataQualifier)

TbData Constructor (TbUnit, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier, NullableDouble, TbDataQualifier)

Toolbox data value description object constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbData(
    TbUnit unit,
    Nullable<double> value,
    TbDataQualifier qualifier,
    Nullable<double> minValue,
    TbDataQualifier minQualifier,
    Nullable<double> maxValue,
    TbDataQualifier maxQualifier
)

Parameters

unit
Type: Toolbox.Docking.Api.UnitsTbUnit
The Toolbox unit for the data value.
value
Type: SystemNullable Double
Mean value.
qualifier
Type: Toolbox.Docking.Api.DataTbDataQualifier
Qualifier for the mean value.
minValue
Type: SystemNullable Double
Min value for the range.
minQualifier
Type: Toolbox.Docking.Api.DataTbDataQualifier
Min value qualifier.
maxValue
Type: SystemNullable Double
Max value for the range.
maxQualifier
Type: Toolbox.Docking.Api.DataTbDataQualifier
Max value qualifier.
See Also

Reference

TbData Class
TbData Overload
Toolbox.Docking.Api.Data Namespace


TbData Properties

The TbData type exposes the following members.

Properties
 | Name | Description
Public property | MaxQualifier | Max value for the range.
Public property | MaxValue | Max value for the range.
Public property | MinQualifier | Min value qualifier.
Public property | MinValue | Min value for the range.
Public property | Qualifier | Value qualifier. (Inherited from TbScalarData.)
Public property | Unit | The unit of this data. (Inherited from TbScalarData.)
Public property | Value | The value of this data. (Inherited from TbScalarData.)
Top
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData.MaxQualifier Property

TbDataMaxQualifier Property

Max value for the range.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDataQualifier MaxQualifier { get; }

Property Value

Type: TbDataQualifier
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData.MaxValue Property

TbDataMaxValue Property

Max value for the range.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<double> MaxValue { get; }

Property Value

Type: Nullable Double
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData.MinQualifier Property

TbDataMinQualifier Property

Min value qualifier.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDataQualifier MinQualifier { get; }

Property Value

Type: TbDataQualifier
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData.MinValue Property

TbDataMinValue Property

Min value for the range.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<double> MinValue { get; }

Property Value

Type: Nullable Double
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbData Methods

The TbData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbData Class
Toolbox.Docking.Api.Data Namespace


TbDataQualifier Enumeration

Represents values qualifiers

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum TbDataQualifier
Members
Member name | Value | Description
None | 0 | No qualifiers
Equal | 1 | Equal value qualifier
LessOrEqual | 3 | Less or equal value qualifier
Lower | 4 | Less value qualifier
Greater | 5 | Greater value qualifier
GreaterOrEqual | 6 | Greater or equal value qualifier
NotEqual | 7 | Not equal value qualifier
Circa | 8 | Circa value qualifier
ClosedRange | 10 | Closed range qualifier
See Also

Reference

Toolbox.Docking.Api.Data Namespace


TbDescribedData Class

Toolbox data value with associated metadata
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.DataTbDescribedData

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbDescribedData

The TbDescribedData type exposes the following members.

Constructors
 | Name | Description
Public method | TbDescribedData | Initializes a new instance of the TbDescribedData class
Top
Properties
 | Name | Description
Public property | Data | The data value.
Public property | Metadata | The assigned metadata.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Data Namespace


TbDescribedData Constructor

Initializes a new instance of the TbDescribedData class

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDescribedData(
    TbData data,
    TbMetadata metadata
)

Parameters

data
Type: Toolbox.Docking.Api.DataTbData
The Toolbox data value object
metadata
Type: Toolbox.Docking.Api.DataTbMetadata
The assigned metadata
See Also

Reference

TbDescribedData Class
Toolbox.Docking.Api.Data Namespace


TbDescribedData Properties

The TbDescribedData type exposes the following members.

Properties
 | Name | Description
Public property | Data | The data value.
Public property | Metadata | The assigned metadata.
Top
See Also

Reference

TbDescribedData Class
Toolbox.Docking.Api.Data Namespace


TbDescribedData.Data Property

TbDescribedDataData Property

The data value.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbData Data { get; }

Property Value

Type: TbData
See Also

Reference

TbDescribedData Class
Toolbox.Docking.Api.Data Namespace


TbDescribedData.Metadata Property

TbDescribedDataMetadata Property

The assigned metadata.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbMetadata Metadata { get; }

Property Value

Type: TbMetadata
See Also

Reference

TbDescribedData Class
Toolbox.Docking.Api.Data Namespace


TbDescribedData Methods

The TbDescribedData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbDescribedData Class
Toolbox.Docking.Api.Data Namespace


TbMetadata Class

Toolbox metadata object.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.DataTbMetadata

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbMetadata

The TbMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | TbMetadata | Toolbox metadata object constructor.
Top
Properties
 | Name | Description
Public property | StringMetadata | Text metadata value pairs (e.g. Endpoint=EC50).
Public property | ValueMetadata | Numerical, structured metadata value i.e. MetadataLabel=Value in a Unit (e.g. Duration = 96 h)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Data Namespace


TbMetadata Constructor

Toolbox metadata object constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbMetadata(
    IReadOnlyDictionary<string, string> stringMetadata,
    IReadOnlyDictionary<string, TbData> valueMetadata
)

Parameters

stringMetadata
Type: System.Collections.GenericIReadOnlyDictionary String, String
The list with string metadata values.
valueMetadata
Type: System.Collections.GenericIReadOnlyDictionary String, TbData
The list with TbData numerical values.
See Also

Reference

TbMetadata Class
Toolbox.Docking.Api.Data Namespace


TbMetadata Properties

The TbMetadata type exposes the following members.

Properties
 | Name | Description
Public property | StringMetadata | Text metadata value pairs (e.g. Endpoint=EC50).
Public property | ValueMetadata | Numerical, structured metadata value i.e. MetadataLabel=Value in a Unit (e.g. Duration = 96 h)
Top
See Also

Reference

TbMetadata Class
Toolbox.Docking.Api.Data Namespace


TbMetadata.StringMetadata Property

TbMetadataStringMetadata Property

Text metadata value pairs (e.g. Endpoint=EC50).

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyDictionary<string, string> StringMetadata { get; }

Property Value

Type: IReadOnlyDictionary String, String
See Also

Reference

TbMetadata Class
Toolbox.Docking.Api.Data Namespace


TbMetadata.ValueMetadata Property

TbMetadataValueMetadata Property

Numerical, structured metadata value i.e. MetadataLabel=Value in a Unit (e.g. Duration = 96 h)

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyDictionary<string, TbData> ValueMetadata { get; }

Property Value

Type: IReadOnlyDictionary String, TbData
See Also

Reference

TbMetadata Class
Toolbox.Docking.Api.Data Namespace


TbMetadata Methods

The TbMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbMetadata Class
Toolbox.Docking.Api.Data Namespace


TbScalarData Class

Scalar data value definition object.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.DataTbScalarData
Toolbox.Docking.Api.DataTbData

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public class TbScalarData

The TbScalarData type exposes the following members.

Constructors
 | Name | Description
Public method | TbScalarData(TbScalarData) | Cloned data constructor.
Public method | TbScalarData(TbUnit, NullableDouble) | Unit and value constructor.
Public method | TbScalarData(TbUnit, NullableDouble, TbDataQualifier) | Toolbox scalar value constructor.
Top
Properties
 | Name | Description
Public property | Qualifier | Value qualifier.
Public property | Unit | The unit of this data.
Public property | Value | The value of this data.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Data Namespace


TbScalarData Constructor

Overload List
 | Name | Description
Public method | TbScalarData(TbScalarData) | Cloned data constructor.
Public method | TbScalarData(TbUnit, NullableDouble) | Unit and value constructor.
Public method | TbScalarData(TbUnit, NullableDouble, TbDataQualifier) | Toolbox scalar value constructor.
Top
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


TbScalarData Constructor (TbScalarData)

Cloned data constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbScalarData(
    TbScalarData data
)

Parameters

data
Type: Toolbox.Docking.Api.DataTbScalarData
Scalar to be cloned.
See Also

Reference

TbScalarData Class
TbScalarData Overload
Toolbox.Docking.Api.Data Namespace


TbScalarData Constructor (TbUnit, Nullable(Double))

TbScalarData Constructor (TbUnit, NullableDouble)

Unit and value constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbScalarData(
    TbUnit unit,
    Nullable<double> value
)

Parameters

unit
Type: Toolbox.Docking.Api.UnitsTbUnit
Toolbox unit of the scalar value.
value
Type: SystemNullable Double
The value for the scalar.
See Also

Reference

TbScalarData Class
TbScalarData Overload
Toolbox.Docking.Api.Data Namespace


TbScalarData Constructor (TbUnit, Nullable(Double), TbDataQualifier)

TbScalarData Constructor (TbUnit, NullableDouble, TbDataQualifier)

Toolbox scalar value constructor.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbScalarData(
    TbUnit unit,
    Nullable<double> value,
    TbDataQualifier qualifier
)

Parameters

unit
Type: Toolbox.Docking.Api.UnitsTbUnit
Toolbox unit of the scalar value.
value
Type: SystemNullable Double
The value for the scalar.
qualifier
Type: Toolbox.Docking.Api.DataTbDataQualifier
Qualifier for the value.
See Also

Reference

TbScalarData Class
TbScalarData Overload
Toolbox.Docking.Api.Data Namespace


TbScalarData Properties

The TbScalarData type exposes the following members.

Properties
 | Name | Description
Public property | Qualifier | Value qualifier.
Public property | Unit | The unit of this data.
Public property | Value | The value of this data.
Top
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


TbScalarData.Qualifier Property

TbScalarDataQualifier Property

Value qualifier.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbDataQualifier Qualifier { get; }

Property Value

Type: TbDataQualifier
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


TbScalarData.Unit Property

TbScalarDataUnit Property

The unit of this data.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbUnit Unit { get; }

Property Value

Type: TbUnit
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


TbScalarData.Value Property

TbScalarDataValue Property

The value of this data.

Namespace: Toolbox.Docking.Api.Data
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<double> Value { get; }

Property Value

Type: Nullable Double
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


TbScalarData Methods

The TbScalarData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbScalarData Class
Toolbox.Docking.Api.Data Namespace


Toolbox.Docking.Api.ExtraActions Namespace

Classes
 | Class | Description
Public class | TbExtraActionDefinition | Description for a Toolbox extra action.
Public class | TbExtraActionResult | Definition for a Toolbox extra action result
Enumerations
 | Enumeration | Description
Public enumeration | TbExtraActionTarget | Binding target for an extra action.


TbExtraActionDefinition Class

Description for a Toolbox extra action.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ExtraActionsTbExtraActionDefinition

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbExtraActionDefinition

The TbExtraActionDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | TbExtraActionDefinition | Create in instance of ExtraActionDefinition
Top
Properties
 | Name | Description
Public property | Caption | Caption of this action
Public property | ClientModule | If this is empty the client directly call server to execute action If contains a name of client's module (IToolboxPlugin) then this module is just executed without any call to server
Public property | Guid | ID of this action
Public property | Target | Target of this action.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition Constructor

Create in instance of ExtraActionDefinition

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbExtraActionDefinition(
    string caption,
    Guid guid,
    TbExtraActionTarget target,
    string clientModule = null
)

Parameters

caption
Type: SystemString
Caption for the extra action.
guid
Type: SystemGuid
Unique identifier for the extra action.
target
Type: Toolbox.Docking.Api.ExtraActionsTbExtraActionTarget
Target for the extra action. Controls where in the UI the action will be available and to what it will pertain to.
clientModule (Optional)
Type: SystemString
Optional client side module name.
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition Properties

The TbExtraActionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption of this action
Public property | ClientModule | If this is empty the client directly call server to execute action If contains a name of client's module (IToolboxPlugin) then this module is just executed without any call to server
Public property | Guid | ID of this action
Public property | Target | Target of this action.
Top
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition.Caption Property

TbExtraActionDefinitionCaption Property

Caption of this action

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Caption { get; }

Property Value

Type: String
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition.ClientModule Property

TbExtraActionDefinitionClientModule Property

If this is empty the client directly call server to execute action If contains a name of client's module (IToolboxPlugin) then this module is just executed without any call to server

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string ClientModule { get; }

Property Value

Type: String
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition.Guid Property

TbExtraActionDefinitionGuid Property

ID of this action

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Guid Guid { get; }

Property Value

Type: Guid
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition.Target Property

TbExtraActionDefinitionTarget Property

Target of this action.

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbExtraActionTarget Target { get; }

Property Value

Type: TbExtraActionTarget
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionDefinition Methods

The TbExtraActionDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbExtraActionDefinition Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult Class

Definition for a Toolbox extra action result
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ExtraActionsTbExtraActionResult

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbExtraActionResult

The TbExtraActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | TbExtraActionResult | Constructor for the result object
Top
Properties
 | Name | Description
Public property | Explainer | Name of client's plugin (IToolboxPluginExplain) wich can explain this result
Public property | Payload | string coded result.
Public property | Result | integer result
Top
Methods
 | Name | Description
 | EmptyResult | Create an empty extra action result
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult Constructor

Constructor for the result object

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbExtraActionResult(
    int result,
    string payload,
    string explainer
)

Parameters

result
Type: SystemInt32
Integer value for the action result
payload
Type: SystemString
String encoded payload. Encoding/Decoding of the payload string is left to the Server/Client implementation of the addin
explainer
Type: SystemString
Name of client's plugin (IToolboxPluginExplain) wich can explain this result
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult Properties

The TbExtraActionResult type exposes the following members.

Properties
 | Name | Description
Public property | Explainer | Name of client's plugin (IToolboxPluginExplain) wich can explain this result
Public property | Payload | string coded result.
Public property | Result | integer result
Top
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult.Explainer Property

TbExtraActionResultExplainer Property

Name of client's plugin (IToolboxPluginExplain) wich can explain this result

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Explainer { get; }

Property Value

Type: String
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult.Payload Property

TbExtraActionResultPayload Property

string coded result.

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Payload { get; }

Property Value

Type: String
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult.Result Property

TbExtraActionResultResult Property

integer result

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Result { get; }

Property Value

Type: Int32
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult Methods

The TbExtraActionResult type exposes the following members.

Methods
 | Name | Description
 | EmptyResult | Create an empty extra action result
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionResult.EmptyResult Method

TbExtraActionResultEmptyResult Method

Create an empty extra action result

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static TbExtraActionResult EmptyResult()

Return Value

Type: TbExtraActionResult
The constructed extra action result.
See Also

Reference

TbExtraActionResult Class
Toolbox.Docking.Api.ExtraActions Namespace


TbExtraActionTarget Enumeration

Binding target for an extra action.

Namespace: Toolbox.Docking.Api.ExtraActions
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum TbExtraActionTarget
Members
Member name | Value | Description
NonSpecific | 0 | Reserved.
Chemical | 1 | Action that works on a single chemical.
ToolboxObject | 2 | Action that works on a Toolbox object.
See Also

Reference

Toolbox.Docking.Api.ExtraActions Namespace


Toolbox.Docking.Api.Objects Namespace

Classes
 | Class | Description
Public class | TbObjectAbout | A class containing the about information for the Toolbox object (QSAR, calculator, profile etc.). This will be displayed on various places within the Toolbox Client's UI most often via an About button.
Public class | TbObjectAboutTextPair | A class for providing additional information for TbObjectAbout in the form of label-value pairs. The label is the name (or title) of the piece of information and the value is the actual information
Public class | TbObjectId | Basic class for describing a Toolbox object. This is used throughout Toolbox as an object identifiers.
Public class | TbObjectInfo | Base class for object information
Interfaces
 | Interface | Description
Public interface | ITbObject | Base interface representing a Toolbox object.
Public interface | ITbObjectDomain | Object with Domain
Public interface | ITbObjectExtraAction | Object extra action definition.
Public interface | ITbObjectFactory | Base declaration for Toolbox object factories. Contains all common static information for set of Toolbox objects. All properties should return valid values even before the call of InitFactory(IListString, ITbInitTask).
Public interface | ITbObjectFactoryDelete | The object factory class implementing the interface declares that it has a method for deleting. Whether the object can be deleted or not is further controlled by the IObjectFactory.Flags attribute
Public interface | ITbObjectFactoryDomain | Object factory with Domain
Public interface | ITbObjectFactoryExplain | Defines an object factory which have corresponding client side module for result explanation
Public interface | ITbObjectFactoryExtraAction | Factory, which objects have some additional functionalites. These will be displayed onto context menus for Toolbox objects, chemicals etc...
Public interface | ITbObjectFactoryTunable | Factory for objects which have options. The objects (calculators, profilers, metabolisms or qsars) produced from this factory must implement ITbTunableObject. Tunable objects are not cashed from the system!
Public interface | ITbObjectFactoryView | Object factory with client side visualization
Public interface | ITbObjectTunable | Interface for object which has options to adjust
Enumerations
 | Enumeration | Description
Public enumeration | TbDomainStatus | DomainStatus results
Public enumeration | TbObjectFlags | Toolbox object's metadata flags
Public enumeration | TbObjectInfoFlags | Flags representing object's basic properties


ITbObject Interface

Base interface representing a Toolbox object.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObject : IDisposable

The ITbObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObject Methods

The ITbObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

ITbObject Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectDomain Interface

Object with Domain

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectDomain

The ITbObjectDomain type exposes the following members.

Methods
 | Name | Description
Public method | CheckDomain | Determines whether a particular chemical falls within the applicability domain of the Toolbox API object
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectDomain Methods

The ITbObjectDomain type exposes the following members.

Methods
 | Name | Description
Public method | CheckDomain | Determines whether a particular chemical falls within the applicability domain of the Toolbox API object
Top
See Also

Reference

ITbObjectDomain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectDomain.CheckDomain Method

ITbObjectDomainCheckDomain Method

Determines whether a particular chemical falls within the applicability domain of the Toolbox API object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbDomainStatus CheckDomain(
    ITbBasket basket
)

Parameters

basket
Type: Toolbox.Docking.Api.ControlITbBasket

Return Value

Type: TbDomainStatus
Text we see in Help File
See Also

Reference

ITbObjectDomain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectExtraAction Interface

Object extra action definition.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectExtraAction : ITbObject,
    IDisposable

The ITbObjectExtraAction type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecuteExtraAction | Executes a Toolbox object's extra action. As provided by the GetExtraActions method.
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectExtraAction Methods

The ITbObjectExtraAction type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExecuteExtraAction | Executes a Toolbox object's extra action. As provided by the GetExtraActions method.
Top
See Also

Reference

ITbObjectExtraAction Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectExtraAction.ExecuteExtraAction Method

ITbObjectExtraActionExecuteExtraAction Method

Executes a Toolbox object's extra action. As provided by the GetExtraActions method.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbExtraActionResult ExecuteExtraAction(
    Guid action,
    int command,
    string payload,
    ITbBasket target
)

Parameters

action
Type: SystemGuid
The ID of the action.
command
Type: SystemInt32
Command for the action.
payload
Type: SystemString
String encoded payload for the action.
target
Type: Toolbox.Docking.Api.ControlITbBasket
Target chemical

Return Value

Type: TbExtraActionResult
Returns the actions's TbExtraActionResult
See Also

Reference

ITbObjectExtraAction Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory Interface

Base declaration for Toolbox object factories. Contains all common static information for set of Toolbox objects. All properties should return valid values even before the call of InitFactory(IListString, ITbInitTask).

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactory

The ITbObjectFactory type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints.
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button.
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes.
Top
Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once.
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory Properties

The ITbObjectFactory type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints.
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button.
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes.
Top
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory.Flags Property

ITbObjectFactoryFlags Property

Provides the metadata describing the object's capabilities/constraints.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbObjectFlags Flags { get; }

Property Value

Type: TbObjectFlags
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory.ObjectAbout Property

ITbObjectFactoryObjectAbout Property

Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbObjectAbout ObjectAbout { get; }

Property Value

Type: TbObjectAbout
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory.ObjectId Property

ITbObjectFactoryObjectId Property

Provides the object identification. This would be used throughout the application. For visualization and accounting purposes.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbObjectId ObjectId { get; }

Property Value

Type: TbObjectId
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory Methods

The ITbObjectFactory type exposes the following members.

Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once.
Top
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactory.InitFactory Method

ITbObjectFactoryInitFactory Method

Initializes the factory. The method should be called once.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool InitFactory(
    IList<string> errorLog,
    ITbInitTask initTask
)

Parameters

errorLog
Type: System.Collections.GenericIList String
Used to return error log to the calling method.
initTask
Type: Toolbox.Docking.Api.ControlITbInitTask
Provides basic workflow control as well as access to Toolbox services.

Return Value

Type: Boolean
Returns true if the initialization was successful. Factory initialization is used in IObjectFactory descendants (e.g. ITbCalculatorFactory, ITbMetabolismFactory, ITbProfilerFactory, ITbQsarFactory) to have the necessary initializations performed. Only after initialization the IObjectFactory descendants' methods return a valid result.
See Also

Reference

ITbObjectFactory Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDelete Interface

The object factory class implementing the interface declares that it has a method for deleting. Whether the object can be deleted or not is further controlled by the IObjectFactory.Flags attribute

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryDelete : ITbObjectFactory

The ITbObjectFactoryDelete type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | Delete | This method should free resources, remove configurations, un-register the object or whatever is required to stop the object from docking into the system anymore.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDelete Properties

The ITbObjectFactoryDelete type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryDelete Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDelete Methods

The ITbObjectFactoryDelete type exposes the following members.

Methods
 | Name | Description
Public method | Delete | This method should free resources, remove configurations, un-register the object or whatever is required to stop the object from docking into the system anymore.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryDelete Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDelete.Delete Method

ITbObjectFactoryDeleteDelete Method

This method should free resources, remove configurations, un-register the object or whatever is required to stop the object from docking into the system anymore.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool Delete()

Return Value

Type: Boolean
Return true if the object has been successfully removed.
See Also

Reference

ITbObjectFactoryDelete Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDomain Interface

Object factory with Domain

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryDomain : ITbObjectFactory

The ITbObjectFactoryDomain type exposes the following members.

Properties
 | Name | Description
Public property | ClientDomainExplainer | Client side explain module which is used to visualize domain for a chemical If this string is null or empty, the QSAR model is considered to not have domain visualizer. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbDomainVisualizer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDomain Properties

The ITbObjectFactoryDomain type exposes the following members.

Properties
 | Name | Description
Public property | ClientDomainExplainer | Client side explain module which is used to visualize domain for a chemical If this string is null or empty, the QSAR model is considered to not have domain visualizer. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbDomainVisualizer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryDomain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDomain.ClientDomainExplainer Property

ITbObjectFactoryDomainClientDomainExplainer Property

Client side explain module which is used to visualize domain for a chemical If this string is null or empty, the QSAR model is considered to not have domain visualizer. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbDomainVisualizer

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ClientDomainExplainer { get; }

Property Value

Type: String
See Also

Reference

ITbObjectFactoryDomain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryDomain Methods

The ITbObjectFactoryDomain type exposes the following members.

Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryDomain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExplain Interface

Defines an object factory which have corresponding client side module for result explanation

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryExplain : ITbObjectFactory

The ITbObjectFactoryExplain type exposes the following members.

Properties
 | Name | Description
Public property | ClientExplainModule | Client side explain module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbResultExplainer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExplain Properties

The ITbObjectFactoryExplain type exposes the following members.

Properties
 | Name | Description
Public property | ClientExplainModule | Client side explain module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbResultExplainer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryExplain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExplain.ClientExplainModule Property

ITbObjectFactoryExplainClientExplainModule Property

Client side explain module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbResultExplainer

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ClientExplainModule { get; }

Property Value

Type: String
See Also

Reference

ITbObjectFactoryExplain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExplain Methods

The ITbObjectFactoryExplain type exposes the following members.

Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryExplain Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExtraAction Interface

Factory, which objects have some additional functionalites. These will be displayed onto context menus for Toolbox objects, chemicals etc...

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryExtraAction : ITbObjectFactory

The ITbObjectFactoryExtraAction type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | GetExtraActions | Return the list of actions the provider implements.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExtraAction Properties

The ITbObjectFactoryExtraAction type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryExtraAction Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExtraAction Methods

The ITbObjectFactoryExtraAction type exposes the following members.

Methods
 | Name | Description
Public method | GetExtraActions | Return the list of actions the provider implements.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryExtraAction Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryExtraAction.GetExtraActions Method

ITbObjectFactoryExtraActionGetExtraActions Method

Return the list of actions the provider implements.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IEnumerable<TbExtraActionDefinition> GetExtraActions()

Return Value

Type: IEnumerable TbExtraActionDefinition
List of TbExtraActionDefinition
See Also

Reference

ITbObjectFactoryExtraAction Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable Interface

Factory for objects which have options. The objects (calculators, profilers, metabolisms or qsars) produced from this factory must implement ITbTunableObject. Tunable objects are not cashed from the system!

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryTunable : ITbObjectFactory

The ITbObjectFactoryTunable type exposes the following members.

Properties
 | Name | Description
Public property | ClientOptionsModule | Client side options module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbOptionsPlugin
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | FormatOptions | Convert serialized options to human readable string rows. Used for reporting of options.
Public method | GetDefaultOptions | Returns the default options of the object serialized to string.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable Properties

The ITbObjectFactoryTunable type exposes the following members.

Properties
 | Name | Description
Public property | ClientOptionsModule | Client side options module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbOptionsPlugin
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable.ClientOptionsModule Property

ITbObjectFactoryTunableClientOptionsModule Property

Client side options module identification. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbOptionsPlugin

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ClientOptionsModule { get; }

Property Value

Type: String
See Also

Reference

ITbObjectFactoryTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable Methods

The ITbObjectFactoryTunable type exposes the following members.

Methods
 | Name | Description
Public method | FormatOptions | Convert serialized options to human readable string rows. Used for reporting of options.
Public method | GetDefaultOptions | Returns the default options of the object serialized to string.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable.FormatOptions Method

ITbObjectFactoryTunableFormatOptions Method

Convert serialized options to human readable string rows. Used for reporting of options.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<string> FormatOptions(
    string options
)

Parameters

options
Type: SystemString
The options encoded as string

Return Value

Type: IReadOnlyList String
Prepares a UI friendly string of the object's options
See Also

Reference

ITbObjectFactoryTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryTunable.GetDefaultOptions Method

ITbObjectFactoryTunableGetDefaultOptions Method

Returns the default options of the object serialized to string.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetDefaultOptions(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
The task to be used for notifications and flow control.

Return Value

Type: String
Returns the options set. If no options return String.Empty.
See Also

Reference

ITbObjectFactoryTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryView Interface

Object factory with client side visualization

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectFactoryView : ITbObjectFactory

The ITbObjectFactoryView type exposes the following members.

Properties
 | Name | Description
Public property | ClientViewModule | Client side view module which is used to visualize. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbObjectVisualizer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryView Properties

The ITbObjectFactoryView type exposes the following members.

Properties
 | Name | Description
Public property | ClientViewModule | Client side view module which is used to visualize. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbObjectVisualizer
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryView Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryView.ClientViewModule Property

ITbObjectFactoryViewClientViewModule Property

Client side view module which is used to visualize. Client side modules are loaded using Managed Extensibility Framework (MEF) See ITbObjectVisualizer

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ClientViewModule { get; }

Property Value

Type: String
See Also

Reference

ITbObjectFactoryView Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectFactoryView Methods

The ITbObjectFactoryView type exposes the following members.

Methods
 | Name | Description
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbObjectFactoryView Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectTunable Interface

Interface for object which has options to adjust

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectTunable : ITbObject,
    IDisposable

The ITbObjectTunable type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | SetOptions | Set options to an object. The factory producing this object must be ITbObjectFactoryTunable. The newOptions string is obtained from: factory.DefaultOptions or client implementation of ITbOptionsPlugin Each object is responsible for Serialization/Deserialization to/from string.
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


ITbObjectTunable Methods

The ITbObjectTunable type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | SetOptions | Set options to an object. The factory producing this object must be ITbObjectFactoryTunable. The newOptions string is obtained from: factory.DefaultOptions or client implementation of ITbOptionsPlugin Each object is responsible for Serialization/Deserialization to/from string.
Top
See Also

Reference

ITbObjectTunable Interface
Toolbox.Docking.Api.Objects Namespace


ITbObjectTunable.SetOptions Method

ITbObjectTunableSetOptions Method

Set options to an object. The factory producing this object must be ITbObjectFactoryTunable. The newOptions string is obtained from: factory.DefaultOptions or client implementation of ITbOptionsPlugin Each object is responsible for Serialization/Deserialization to/from string.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void SetOptions(
    string newOptions
)

Parameters

newOptions
Type: SystemString
The new options to be set.
See Also

Reference

ITbObjectTunable Interface
Toolbox.Docking.Api.Objects Namespace


TbDomainStatus Enumeration

DomainStatus results

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum TbDomainStatus
Members
Member name | Value | Description
Undefined | 0 | The QSAR could not determine where the queried chemical falls in the QSAR domain
NotApplicable | 1 | The QSAR has made a determination that the queried chemical cannot be assessed for a place within the domain e.g. QSAR cannot deal with polymers.
OutOfDomain | 2 | The chemical is OUT of the QSAR's domain
InDomain | 3 | The chemical is IN the QSAR's domain
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectAbout Class

A class containing the about information for the Toolbox object (QSAR, calculator, profile etc.). This will be displayed on various places within the Toolbox Client's UI most often via an About button.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectAbout

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbObjectAbout

The TbObjectAbout type exposes the following members.

Constructors
 | Name | Description
Public method | TbObjectAbout | Constructor for object about.
Top
Properties
 | Name | Description
Public property | AdditionalInfo | Additional information provided in name-value pairs
Public property | Authors | Authors of the object
Public property | Description | A description of the object
Public property | Disclaimer | A disclaimer for the object
Public property | Donator | The donator of the object
Public property | HelpFile | The documentation file name (if any). This file is searched in the config directory of the Toolbox object on the server. - If the file is ZIP then it is extracted to a folder on the client. Then the system searches for a file in the folder with the same name as the ZIP and opens by a default program chosen by the OS. - Else the file is saved on the client and opened by a default program chosen by the OS
Public property | Name | The name of the object
Public property | Url | A URL for navigation to additional information about the object
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectAbout Constructor

Constructor for object about.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbObjectAbout(
    string description,
    string donator,
    string disclaimer,
    string authors,
    string url,
    string name,
    string helpFile,
    IEnumerable<TbObjectAboutTextPair> additionalInfo
)

Parameters

description
Type: SystemString
A description of the object
donator
Type: SystemString
The donator of the object
disclaimer
Type: SystemString
A disclaimer for the object
authors
Type: SystemString
Authors of the object
url
Type: SystemString
A URL for navigation to additional information about the object
name
Type: SystemString
The name of the object
helpFile
Type: SystemString
The documentation file name
additionalInfo
Type: System.Collections.GenericIEnumerable TbObjectAboutTextPair
Additional information provided in name-value pairs
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout Properties

The TbObjectAbout type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo | Additional information provided in name-value pairs
Public property | Authors | Authors of the object
Public property | Description | A description of the object
Public property | Disclaimer | A disclaimer for the object
Public property | Donator | The donator of the object
Public property | HelpFile | The documentation file name (if any). This file is searched in the config directory of the Toolbox object on the server. - If the file is ZIP then it is extracted to a folder on the client. Then the system searches for a file in the folder with the same name as the ZIP and opens by a default program chosen by the OS. - Else the file is saved on the client and opened by a default program chosen by the OS
Public property | Name | The name of the object
Public property | Url | A URL for navigation to additional information about the object
Top
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.AdditionalInfo Property

TbObjectAboutAdditionalInfo Property

Additional information provided in name-value pairs

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<TbObjectAboutTextPair> AdditionalInfo { get; }

Property Value

Type: IReadOnlyList TbObjectAboutTextPair
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Authors Property

TbObjectAboutAuthors Property

Authors of the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Authors { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Description Property

TbObjectAboutDescription Property

A description of the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Description { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Disclaimer Property

TbObjectAboutDisclaimer Property

A disclaimer for the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Disclaimer { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Donator Property

TbObjectAboutDonator Property

The donator of the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Donator { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.HelpFile Property

TbObjectAboutHelpFile Property

The documentation file name (if any). This file is searched in the config directory of the Toolbox object on the server. - If the file is ZIP then it is extracted to a folder on the client. Then the system searches for a file in the folder with the same name as the ZIP and opens by a default program chosen by the OS. - Else the file is saved on the client and opened by a default program chosen by the OS

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string HelpFile { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Name Property

TbObjectAboutName Property

The name of the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout.Url Property

TbObjectAboutUrl Property

A URL for navigation to additional information about the object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Url { get; }

Property Value

Type: String
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAbout Methods

The TbObjectAbout type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbObjectAbout Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair Class

A class for providing additional information for TbObjectAbout in the form of label-value pairs. The label is the name (or title) of the piece of information and the value is the actual information
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectAboutTextPair

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbObjectAboutTextPair

The TbObjectAboutTextPair type exposes the following members.

Constructors
 | Name | Description
Public method | TbObjectAboutTextPair | Constructor of the model
Top
Properties
 | Name | Description
Public property | Label | The label (or the name or title) of the actual information
Public property | Value | The value or the actual information
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair Constructor

Constructor of the model

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbObjectAboutTextPair(
    string label,
    string value
)

Parameters

label
Type: SystemString
The label (or the name or title) of the actual information
value
Type: SystemString
The value or the actual information
See Also

Reference

TbObjectAboutTextPair Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair Properties

The TbObjectAboutTextPair type exposes the following members.

Properties
 | Name | Description
Public property | Label | The label (or the name or title) of the actual information
Public property | Value | The value or the actual information
Top
See Also

Reference

TbObjectAboutTextPair Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair.Label Property

TbObjectAboutTextPairLabel Property

The label (or the name or title) of the actual information

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Label { get; }

Property Value

Type: String
See Also

Reference

TbObjectAboutTextPair Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair.Value Property

TbObjectAboutTextPairValue Property

The value or the actual information

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Value { get; }

Property Value

Type: String
See Also

Reference

TbObjectAboutTextPair Class
Toolbox.Docking.Api.Objects Namespace


TbObjectAboutTextPair Methods

The TbObjectAboutTextPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbObjectAboutTextPair Class
Toolbox.Docking.Api.Objects Namespace


TbObjectFlags Enumeration

Toolbox object's metadata flags

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum TbObjectFlags
Members
Member name | Value | Description
None | 0 | No specific flags
WorkWithMixtures | 1 | The object can work with mixtures.
WorkWithTautomericSets | 2 | The object can work with tautomeric sets.
IsThreadSafe | 4 | The object is thread safe.
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectId Class

Basic class for describing a Toolbox object. This is used throughout Toolbox as an object identifiers.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectId

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbObjectId

The TbObjectId type exposes the following members.

Constructors
 | Name | Description
Public method | TbObjectId | Basic object constructor.
Top
Properties
 | Name | Description
Public property | Caption | The name of the Toolbox object.
Public property | Guid | The identifier of the object. This identifier should persist through different Toolbox runs.
Public property | Version | Toolbox object version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns basic information for the object. (Overrides ObjectToString.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectId Constructor

Basic object constructor.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbObjectId(
    string caption,
    Guid guid,
    Version version
)

Parameters

caption
Type: SystemString
The name of the Toolbox object.
guid
Type: SystemGuid
The persistent identifier of the object.
version
Type: SystemVersion
Version of the object
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId Properties

The TbObjectId type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The name of the Toolbox object.
Public property | Guid | The identifier of the object. This identifier should persist through different Toolbox runs.
Public property | Version | Toolbox object version.
Top
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId.Caption Property

TbObjectIdCaption Property

The name of the Toolbox object.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Caption { get; }

Property Value

Type: String
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId.Guid Property

TbObjectIdGuid Property

The identifier of the object. This identifier should persist through different Toolbox runs.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Guid Guid { get; }

Property Value

Type: Guid
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId.Version Property

TbObjectIdVersion Property

Toolbox object version.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Version Version { get; }

Property Value

Type: Version
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId Methods

The TbObjectId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns basic information for the object. (Overrides ObjectToString.)
Top
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectId.ToString Method

TbObjectIdToString Method

Returns basic information for the object.

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public override string ToString()

Return Value

Type: String
UI friendly string representation of the object.
See Also

Reference

TbObjectId Class
Toolbox.Docking.Api.Objects Namespace


TbObjectInfo Class

Base class for object information
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectInfo
Toolbox.Docking.Api.Objects.CalculatorTbCalculatorInfo
Toolbox.Docking.Api.Objects.MetabolismTbMetabolismInfo
Toolbox.Docking.Api.Objects.ProfilerTbProfilerInfo
Toolbox.Docking.Api.Objects.QsarTbQsarInfo

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public abstract class TbObjectInfo

The TbObjectInfo type exposes the following members.

Constructors
 | Name | Description
Protected method | TbObjectInfo | Construct a new object info object
Top
Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


TbObjectInfo Constructor

Construct a new object info object

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected TbObjectInfo(
    TbObjectInfoFlags flags
)

Parameters

flags
Type: Toolbox.Docking.Api.ObjectsTbObjectInfoFlags
Object information flags
See Also

Reference

TbObjectInfo Class
Toolbox.Docking.Api.Objects Namespace


TbObjectInfo Properties

The TbObjectInfo type exposes the following members.

Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags
Top
See Also

Reference

TbObjectInfo Class
Toolbox.Docking.Api.Objects Namespace


TbObjectInfo.ObjectFlags Property

TbObjectInfoObjectFlags Property

Access to object's flags

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbObjectInfoFlags ObjectFlags { get; }

Property Value

Type: TbObjectInfoFlags
See Also

Reference

TbObjectInfo Class
Toolbox.Docking.Api.Objects Namespace


TbObjectInfo Methods

The TbObjectInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbObjectInfo Class
Toolbox.Docking.Api.Objects Namespace


TbObjectInfoFlags Enumeration

Flags representing object's basic properties

Namespace: Toolbox.Docking.Api.Objects
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum TbObjectInfoFlags
Members
Member name | Value | Description
Empty | 0 | No any specific properties
HasOptions | 1 | The object has options (implements ITbObjectTunable)
HasDomain | 2 | The object has domain (implements ITbObjectDomain)
See Also

Reference

Toolbox.Docking.Api.Objects Namespace


Toolbox.Docking.Api.Objects.Calculator Namespace

Classes
 | Class | Description
Public class | TbCalculatorInfo | This class contains the most basic description for a Toolbox calculator.
Interfaces
 | Interface | Description
Public interface | ITbCalculator | Toolbox calculator object.
Public interface | ITbCalculatorFactory | Factory for constructing a Toolbox calculator object.
Enumerations
 | Enumeration | Description
Public enumeration | CalculatorFlags | Toolbox calculator's metadata flags.


CalculatorFlags Enumeration

Toolbox calculator's metadata flags.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum CalculatorFlags
Members
Member name | Value | Description
None | 0 | Empty calculators flag.
ExperimentalData | 1 | The calculator returns pre-existing experimental data.
Is3D | 2 | Calculator returns values based on a 3D structure of the molecule.
Cacheble | 4 | Calculator should be cached in Toolbox database.
See Also

Reference

Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculator Interface

Toolbox calculator object.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbCalculator : ITbObject,
    IDisposable

The ITbCalculator type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculate parameter value.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculator Methods

The ITbCalculator type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculate parameter value.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

ITbCalculator Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculator.Calculate Method

ITbCalculatorCalculate Method

Calculate parameter value.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScalarData Calculate(
    ITbBasket target
)

Parameters

target
Type: Toolbox.Docking.Api.ControlITbBasket
The target basket, containing the Toolbox.Docking.Api.Chemical

Return Value

Type: TbScalarData
Return calculated value for the Chemical in the target work basket. NOTE: The resulting TbScalarData object should be in the same Unit as the one returned by the ScaleDeclaration of the factory that produced the calculator.
See Also

Reference

ITbCalculator Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory Interface

Factory for constructing a Toolbox calculator object.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbCalculatorFactory : ITbObjectFactory

The ITbCalculatorFactory type exposes the following members.

Properties
 | Name | Description
Public property | CalculatorFlags | Description of the calculator.
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ScaleDeclaration | This is the scale definition for the Unit that the calculator will return values in. Calculate(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertable for system scales); for TbQualitativeScale the calculated unit must be member of this scale.
Top
Methods
 | Name | Description
Public method | GetCalculator | Returns an initialized, ready to use Toolbox calculator.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory Properties

The ITbCalculatorFactory type exposes the following members.

Properties
 | Name | Description
Public property | CalculatorFlags | Description of the calculator.
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ScaleDeclaration | This is the scale definition for the Unit that the calculator will return values in. Calculate(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertable for system scales); for TbQualitativeScale the calculated unit must be member of this scale.
Top
See Also

Reference

ITbCalculatorFactory Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory.CalculatorFlags Property

ITbCalculatorFactoryCalculatorFlags Property

Description of the calculator.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
CalculatorFlags CalculatorFlags { get; }

Property Value

Type: CalculatorFlags
See Also

Reference

ITbCalculatorFactory Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory.ScaleDeclaration Property

ITbCalculatorFactoryScaleDeclaration Property

This is the scale definition for the Unit that the calculator will return values in. Calculate(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertable for system scales); for TbQualitativeScale the calculated unit must be member of this scale.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScale ScaleDeclaration { get; }

Property Value

Type: TbScale
See Also

Reference

ITbCalculatorFactory Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory Methods

The ITbCalculatorFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetCalculator | Returns an initialized, ready to use Toolbox calculator.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbCalculatorFactory Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


ITbCalculatorFactory.GetCalculator Method

ITbCalculatorFactoryGetCalculator Method

Returns an initialized, ready to use Toolbox calculator.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbCalculator GetCalculator(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Task responsible for the object initialization

Return Value

Type: ITbCalculator
The initialized Toolbox calculator.
See Also

Reference

ITbCalculatorFactory Interface
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo Class

This class contains the most basic description for a Toolbox calculator.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectInfo
Toolbox.Docking.Api.Objects.CalculatorTbCalculatorInfo

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbCalculatorInfo : TbObjectInfo

The TbCalculatorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TbCalculatorInfo | Constructs a calculator info object.
Top
Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Flags | Toolbox calculator's metadata flags.
Public field | Unit | This is the Unit that the calculator will return values in. Toolbox calculators should return all calculated values in a single unit.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo Constructor

Constructs a calculator info object.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbCalculatorInfo(
    TbObjectInfoFlags objFlags,
    TbUnit unit,
    CalculatorFlags flags
)

Parameters

objFlags
Type: Toolbox.Docking.Api.ObjectsTbObjectInfoFlags
Object information flags
unit
Type: Toolbox.Docking.Api.UnitsTbUnit
The Unit that the calculator will return values in
flags
Type: Toolbox.Docking.Api.Objects.CalculatorCalculatorFlags
Toolbox calculator's metadata flags.
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo Properties

The TbCalculatorInfo type exposes the following members.

Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo Methods

The TbCalculatorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo Fields

The TbCalculatorInfo type exposes the following members.

Fields
 | Name | Description
Public field | Flags | Toolbox calculator's metadata flags.
Public field | Unit | This is the Unit that the calculator will return values in. Toolbox calculators should return all calculated values in a single unit.
Top
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo.Flags Field

TbCalculatorInfoFlags Field

Toolbox calculator's metadata flags.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly CalculatorFlags Flags

Field Value

Type: CalculatorFlags
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


TbCalculatorInfo.Unit Field

TbCalculatorInfoUnit Field

This is the Unit that the calculator will return values in. Toolbox calculators should return all calculated values in a single unit.

Namespace: Toolbox.Docking.Api.Objects.Calculator
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly TbUnit Unit

Field Value

Type: TbUnit
See Also

Reference

TbCalculatorInfo Class
Toolbox.Docking.Api.Objects.Calculator Namespace


Toolbox.Docking.Api.Objects.Metabolism Namespace

Classes
 | Class | Description
Public class | MetabolResult | Class representing a Toolbox metaboliser result.
Public class | TbMetabolismInfo | This class contains the most basic description for a Toolbox metabolism.
Interfaces
 | Interface | Description
Public interface | ITbMetabolism | Toolbox metabolism object.
Public interface | ITbMetabolismFactory | Factory for constructing a Toolbox metabolism object.
Enumerations
 | Enumeration | Description
Public enumeration | MetabolismFlags | Metabolizer metadata flags.


ITbMetabolism Interface

Toolbox metabolism object.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbMetabolism : ITbObject,
    IDisposable

The ITbMetabolism type exposes the following members.

Methods
 | Name | Description
Public method | AlternativeObserved | Returns the number of alternative metabolisms for the target chemical. For instance when there are two observed metabolite trees for a chemical.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetProducts | Metabolizes the chemical in the target work basket.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolism Methods

The ITbMetabolism type exposes the following members.

Methods
 | Name | Description
Public method | AlternativeObserved | Returns the number of alternative metabolisms for the target chemical. For instance when there are two observed metabolite trees for a chemical.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetProducts | Metabolizes the chemical in the target work basket.
Top
See Also

Reference

ITbMetabolism Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolism.AlternativeObserved Method

ITbMetabolismAlternativeObserved Method

Returns the number of alternative metabolisms for the target chemical. For instance when there are two observed metabolite trees for a chemical.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
int AlternativeObserved(
    ITbBasket target
)

Parameters

target
Type: Toolbox.Docking.Api.ControlITbBasket
The basket

Return Value

Type: Int32
Number of metabolte trees.
See Also

Reference

ITbMetabolism Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolism.GetProducts Method

ITbMetabolismGetProducts Method

Metabolizes the chemical in the target work basket.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
MetabolResult GetProducts(
    ITbBasket target,
    int alternativeObserved
)

Parameters

target
Type: Toolbox.Docking.Api.ControlITbBasket
The basket containing the chemical to be metabolized.
alternativeObserved
Type: SystemInt32
If the AlternativeObserved has indicated multiple available metabolisms this is used to specify which one should be returned.

Return Value

Type: MetabolResult
The resulting MetaboResult.
See Also

Reference

ITbMetabolism Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory Interface

Factory for constructing a Toolbox metabolism object.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbMetabolismFactory : ITbObjectFactory

The ITbMetabolismFactory type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | MetabolismType | Description of the metabolism.
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ProductName | This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product").
Top
Methods
 | Name | Description
Public method | GetMetabolism | Returns an initialized, ready to use Toolbox metabolism.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory Properties

The ITbMetabolismFactory type exposes the following members.

Properties
 | Name | Description
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | MetabolismType | Description of the metabolism.
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ProductName | This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product").
Top
See Also

Reference

ITbMetabolismFactory Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory.MetabolismType Property

ITbMetabolismFactoryMetabolismType Property

Description of the metabolism.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
MetabolismFlags MetabolismType { get; }

Property Value

Type: MetabolismFlags
See Also

Reference

ITbMetabolismFactory Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory.ProductName Property

ITbMetabolismFactoryProductName Property

This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product").

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ProductName { get; }

Property Value

Type: String
See Also

Reference

ITbMetabolismFactory Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory Methods

The ITbMetabolismFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetMetabolism | Returns an initialized, ready to use Toolbox metabolism.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbMetabolismFactory Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


ITbMetabolismFactory.GetMetabolism Method

ITbMetabolismFactoryGetMetabolism Method

Returns an initialized, ready to use Toolbox metabolism.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbMetabolism GetMetabolism(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Task responsible for the object initialization

Return Value

Type: ITbMetabolism
The initialized Toolbox metabolism.
See Also

Reference

ITbMetabolismFactory Interface
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolismFlags Enumeration

Metabolizer metadata flags.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum MetabolismFlags
Members
Member name | Value | Description
Observed | 0 | Metabolizer results are observed metabolism data.
Simulated | 1 | Metabolizing results are computer generated.
See Also

Reference

Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Class

Class representing a Toolbox metaboliser result.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.MetabolismMetabolResult

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class MetabolResult

The MetabolResult type exposes the following members.

Constructors
 | Name | Description
Public method | MetabolResult(String) | Constructor for creating a metabolism result that denotes a failed metabolization.
Public method | MetabolResult(NullableSingle, IEnumerableString, IEnumerableNullableSingle) | Constructor for a MetaboResult object.
Top
Properties
 | Name | Description
Public property | Products | Returns the resulting list of metabolism products.
Public property | ProductsQuantities | If the metabolizer calculates quantities this returns the product quantities.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ParentQuantity | If the metabolizer calculates quantities here is where the leftover parent quantity is recorded.
Public field | Remark | Metabolism result may be qualified by a remark.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Constructor

Overload List
 | Name | Description
Public method | MetabolResult(String) | Constructor for creating a metabolism result that denotes a failed metabolization.
Public method | MetabolResult(NullableSingle, IEnumerableString, IEnumerableNullableSingle) | Constructor for a MetaboResult object.
Top
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Constructor (String)

Constructor for creating a metabolism result that denotes a failed metabolization.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public MetabolResult(
    string problem
)

Parameters

problem
Type: SystemString
Information on the metabolizer failure.
See Also

Reference

MetabolResult Class
MetabolResult Overload
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Constructor (Nullable(Single), IEnumerable(String), IEnumerable(Nullable(Single)))

MetabolResult Constructor (NullableSingle, IEnumerableString, IEnumerableNullableSingle)

Constructor for a MetaboResult object.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public MetabolResult(
    Nullable<float> parentQuantity,
    IEnumerable<string> products,
    IEnumerable<Nullable<float>> productsQuantities
)

Parameters

parentQuantity
Type: SystemNullable Single
Leftover parent quantity.
products
Type: System.Collections.GenericIEnumerable String
Metabolism products.
productsQuantities
Type: System.Collections.GenericIEnumerable Nullable Single
Products list.
Remarks
Quantities are recorded in mol/mol parent
See Also

Reference

MetabolResult Class
MetabolResult Overload
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Properties

The MetabolResult type exposes the following members.

Properties
 | Name | Description
Public property | Products | Returns the resulting list of metabolism products.
Public property | ProductsQuantities | If the metabolizer calculates quantities this returns the product quantities.
Top
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult.Products Property

MetabolResultProducts Property

Returns the resulting list of metabolism products.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<string> Products { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult.ProductsQuantities Property

MetabolResultProductsQuantities Property

If the metabolizer calculates quantities this returns the product quantities.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<Nullable<float>> ProductsQuantities { get; }

Property Value

Type: IReadOnlyList Nullable Single
Remarks
Quantities are recorded in mol/mol parent
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Methods

The MetabolResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult Fields

The MetabolResult type exposes the following members.

Fields
 | Name | Description
Public field | ParentQuantity | If the metabolizer calculates quantities here is where the leftover parent quantity is recorded.
Public field | Remark | Metabolism result may be qualified by a remark.
Top
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult.ParentQuantity Field

MetabolResultParentQuantity Field

If the metabolizer calculates quantities here is where the leftover parent quantity is recorded.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly Nullable<float> ParentQuantity

Field Value

Type: Nullable Single
Remarks
Quantities are recorded in mol/mol parent, in this case from 0 to 1.
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


MetabolResult.Remark Field

MetabolResultRemark Field

Metabolism result may be qualified by a remark.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly string Remark

Field Value

Type: String
See Also

Reference

MetabolResult Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo Class

This class contains the most basic description for a Toolbox metabolism.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectInfo
Toolbox.Docking.Api.Objects.MetabolismTbMetabolismInfo

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbMetabolismInfo : TbObjectInfo

The TbMetabolismInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TbMetabolismInfo | Constructs a metabolism info object.
Top
Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | MetabolismType | The metabolism type.Observed or Simulated.
Public field | ProductName | This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product")
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo Constructor

Constructs a metabolism info object.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbMetabolismInfo(
    TbObjectInfoFlags objFlags,
    MetabolismFlags metabolismType,
    string productName
)

Parameters

objFlags
Type: Toolbox.Docking.Api.ObjectsTbObjectInfoFlags
Object information flags
metabolismType
Type: Toolbox.Docking.Api.Objects.MetabolismMetabolismFlags
The metabolism type.Observed or Simulated.
productName
Type: SystemString
This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product")
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo Properties

The TbMetabolismInfo type exposes the following members.

Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo Methods

The TbMetabolismInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo Fields

The TbMetabolismInfo type exposes the following members.

Fields
 | Name | Description
Public field | MetabolismType | The metabolism type.Observed or Simulated.
Public field | ProductName | This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product")
Top
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo.MetabolismType Field

TbMetabolismInfoMetabolismType Field

The metabolism type.Observed or Simulated.

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly MetabolismFlags MetabolismType

Field Value

Type: MetabolismFlags
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


TbMetabolismInfo.ProductName Field

TbMetabolismInfoProductName Field

This is the "metabolism" category name (e.g. "metabolite", "tautomer", "dissociation product")

Namespace: Toolbox.Docking.Api.Objects.Metabolism
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly string ProductName

Field Value

Type: String
See Also

Reference

TbMetabolismInfo Class
Toolbox.Docking.Api.Objects.Metabolism Namespace


Toolbox.Docking.Api.Objects.Profiler Namespace

Classes
 | Class | Description
Public class | TbProfilerInfo | This class contains the most basic description for a Toolbox profiler.
Public class | TbProfilingCategories | Definition of profiling categories list.
Public class | TbProfilingCategoryNode | Profiler category node definition.
Public class | TbToxicologicalProfilerInfoItem | Relevant metadata table for a profiler category node.
Interfaces
 | Interface | Description
Public interface | ITbProfiler | Toolbox profiler object.
Public interface | ITbProfilerFactory | Factory for constructing a Toolbox profiler object.
Enumerations
 | Enumeration | Description
Public enumeration | TbCategoryType | Profiling methods are separated into five groups based on the type of the qualitative information used for chemical assessment. For more information see the F1 help of your latest Toolbox installation.


ITbProfiler Interface

Toolbox profiler object.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbProfiler : ITbObject,
    IDisposable

The ITbProfiler type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCategoriesOf | Return the list of categories a Chemical.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfiler Methods

The ITbProfiler type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCategoriesOf | Return the list of categories a Chemical.
Top
See Also

Reference

ITbProfiler Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfiler.GetCategoriesOf Method

ITbProfilerGetCategoriesOf Method

Return the list of categories a Chemical.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IEnumerable<string> GetCategoriesOf(
    ITbBasket target
)

Parameters

target
Type: Toolbox.Docking.Api.ControlITbBasket
Target basket (chemical) to be tested by the profiler.

Return Value

Type: IEnumerable String
Returns a list of categories for the target chemical. Categories are subset from the AllCategories list.
See Also

Reference

ITbProfiler Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory Interface

Factory for constructing a Toolbox profiler object.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbProfilerFactory : ITbObjectFactory

The ITbProfilerFactory type exposes the following members.

Properties
 | Name | Description
Public property | AllCategories | Returns all the categories of the profiler
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | Hash | If the results are unchangable (can be cached in TB database) this is the unique key representing the profiler state. If results depends on options or something else which makes them not cachable return null
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ProfilerType | Specifies the profiler type.
Top
Methods
 | Name | Description
Public method | GetLiteratureForCategory | Return a link to a HTML file in the local filesystem with more information on the category. This is used by the Client's user interface.
Public method | GetProfiler | Returns an initialized, ready to use Toolbox profiler.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory Properties

The ITbProfilerFactory type exposes the following members.

Properties
 | Name | Description
Public property | AllCategories | Returns all the categories of the profiler
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | Hash | If the results are unchangable (can be cached in TB database) this is the unique key representing the profiler state. If results depends on options or something else which makes them not cachable return null
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | ProfilerType | Specifies the profiler type.
Top
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory.AllCategories Property

ITbProfilerFactoryAllCategories Property

Returns all the categories of the profiler

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbProfilingCategories AllCategories { get; }

Property Value

Type: TbProfilingCategories
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory.Hash Property

ITbProfilerFactoryHash Property

If the results are unchangable (can be cached in TB database) this is the unique key representing the profiler state. If results depends on options or something else which makes them not cachable return null

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Nullable<int> Hash { get; }

Property Value

Type: Nullable Int32
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory.ProfilerType Property

ITbProfilerFactoryProfilerType Property

Specifies the profiler type.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbCategoryType ProfilerType { get; }

Property Value

Type: TbCategoryType
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory Methods

The ITbProfilerFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetLiteratureForCategory | Return a link to a HTML file in the local filesystem with more information on the category. This is used by the Client's user interface.
Public method | GetProfiler | Returns an initialized, ready to use Toolbox profiler.
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Top
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory.GetLiteratureForCategory Method

ITbProfilerFactoryGetLiteratureForCategory Method

Return a link to a HTML file in the local filesystem with more information on the category. This is used by the Client's user interface.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string GetLiteratureForCategory(
    string category
)

Parameters

category
Type: SystemString
The name of the category

Return Value

Type: String
Full file name to an HTML file (to be displayed by a Web control)
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


ITbProfilerFactory.GetProfiler Method

ITbProfilerFactoryGetProfiler Method

Returns an initialized, ready to use Toolbox profiler.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbProfiler GetProfiler(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Task responsible for the object initialization

Return Value

Type: ITbProfiler
The initialized Toolbox profiler
See Also

Reference

ITbProfilerFactory Interface
Toolbox.Docking.Api.Objects.Profiler Namespace


TbCategoryType Enumeration

Profiling methods are separated into five groups based on the type of the qualitative information used for chemical assessment. For more information see the F1 help of your latest Toolbox installation.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public enum TbCategoryType
Members
Member name | Value | Description
Predefined | 0 | Predefined categories are set of rules for grouping chemicals developed by recognized institutions or organizations and they could be considered as “standard” categorization schemes.
Mechanistic | 1 | Mechanistic categorization schemes consist of rules for identification of important chemical characteristics based on published knowledge. Practically they relay on certain hypothesis about the studied phenomenon. In this respect, their application is oriented for the phenomena for which they were developed.
Empiric | 2 | Empiric categorization schemes include rules used to determine the chemical elements constituting the target chemical, its chemical functionality and structural similarity.
Custom | 3 | These are the profiling schemes created by the user. In any case, while creating a new profiler the user may choose to place it in any of the above sections.
Toxicological | 4 | A repeated dose profiler used to identify the toxicological profiler of chemicals. Used for repeated dose toxicity test data extracted from database of Hazard Evaluation Support System (HESS). the profiler is developed by NITE, METI (Japan) in cooperation with LMC
CtEndpointSpecific | 5 | The Endpoint specific category profiler type determines substance properties that are related to specific adverse effects such as acute oral toxicity, bioaccumulation or mutagenicity
ExperimentalData | 6 | Profiler assigning categories based on experimental data
Unknown | 100 |
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo Class

This class contains the most basic description for a Toolbox profiler.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectInfo
Toolbox.Docking.Api.Objects.ProfilerTbProfilerInfo

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbProfilerInfo : TbObjectInfo

The TbProfilerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TbProfilerInfo | Constructor for a profiler info object.
Top
Properties
 | Name | Description
Public property | AllCategories | List with all categories which the profiler can return
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Public property | ProfilerType | Profiler object's type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo Constructor

Constructor for a profiler info object.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbProfilerInfo(
    TbObjectInfoFlags objFlags,
    TbCategoryType profilerType,
    IEnumerable<string> allCategories
)

Parameters

objFlags
Type: Toolbox.Docking.Api.ObjectsTbObjectInfoFlags
Object information flags.
profilerType
Type: Toolbox.Docking.Api.Objects.ProfilerTbCategoryType
The type of profiler.
allCategories
Type: System.Collections.GenericIEnumerable String
List profiler's categories.
See Also

Reference

TbProfilerInfo Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo Properties

The TbProfilerInfo type exposes the following members.

Properties
 | Name | Description
Public property | AllCategories | List with all categories which the profiler can return
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Public property | ProfilerType | Profiler object's type.
Top
See Also

Reference

TbProfilerInfo Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo.AllCategories Property

TbProfilerInfoAllCategories Property

List with all categories which the profiler can return

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<string> AllCategories { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

TbProfilerInfo Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo.ProfilerType Property

TbProfilerInfoProfilerType Property

Profiler object's type.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbCategoryType ProfilerType { get; }

Property Value

Type: TbCategoryType
See Also

Reference

TbProfilerInfo Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilerInfo Methods

The TbProfilerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbProfilerInfo Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Class

Definition of profiling categories list.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.ProfilerTbProfilingCategories

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbProfilingCategories

The TbProfilingCategories type exposes the following members.

Constructors
 | Name | Description
Public method | TbProfilingCategories(IEnumerableTbProfilingCategoryNode, Boolean, String) | Constructor for the profiler catogories list.
Public method | TbProfilingCategories(IEnumerableString, Int32, Boolean, String) | Constructor for the profiler catogories list.
Top
Properties
 | Name | Description
Public property | ChildList | Property for accessing the categories list.
Public property | CounterCategory | Counter category is assigned when no category can be possitivelly assigned to a chemical.
Public property | IsSorted | If true the categoris are sorted by specific order and shoud not be re-sorted by the system alphabetically.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Constructor

Overload List
 | Name | Description
Public method | TbProfilingCategories(IEnumerableTbProfilingCategoryNode, Boolean, String) | Constructor for the profiler catogories list.
Public method | TbProfilingCategories(IEnumerableString, Int32, Boolean, String) | Constructor for the profiler catogories list.
Top
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Constructor (IEnumerable(TbProfilingCategoryNode), Boolean, String)

TbProfilingCategories Constructor (IEnumerableTbProfilingCategoryNode, Boolean, String)

Constructor for the profiler catogories list.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbProfilingCategories(
    IEnumerable<TbProfilingCategoryNode> categories,
    bool isSorted,
    string counterCategory
)

Parameters

categories
Type: System.Collections.GenericIEnumerable TbProfilingCategoryNode
Enumeration of the profiling categories.
isSorted
Type: SystemBoolean
Specifies if the profiler has a preferred sort order for the categories list (to override Toolbox sorting).
counterCategory
Type: SystemString
Counter category is assigned when no category can be possitivelly assigned to a chemical.
See Also

Reference

TbProfilingCategories Class
TbProfilingCategories Overload
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Constructor (IEnumerable(String), Int32, Boolean, String)

TbProfilingCategories Constructor (IEnumerableString, Int32, Boolean, String)

Constructor for the profiler catogories list.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbProfilingCategories(
    IEnumerable<string> categories,
    int version,
    bool isSorted,
    string counterCategory
)

Parameters

categories
Type: System.Collections.GenericIEnumerable String
Enumeration of the profiling categories.
version
Type: SystemInt32
Versioned category list.
isSorted
Type: SystemBoolean
Specifies if the profiler has a preferred sort order for the categories list (to override Toolbox sorting).
counterCategory
Type: SystemString
Counter category is assigned when no category can be possitivelly assigned to a chemical.
See Also

Reference

TbProfilingCategories Class
TbProfilingCategories Overload
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Properties

The TbProfilingCategories type exposes the following members.

Properties
 | Name | Description
Public property | ChildList | Property for accessing the categories list.
Public property | CounterCategory | Counter category is assigned when no category can be possitivelly assigned to a chemical.
Public property | IsSorted | If true the categoris are sorted by specific order and shoud not be re-sorted by the system alphabetically.
Top
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories.ChildList Property

TbProfilingCategoriesChildList Property

Property for accessing the categories list.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<TbProfilingCategoryNode> ChildList { get; }

Property Value

Type: IReadOnlyList TbProfilingCategoryNode
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories.CounterCategory Property

TbProfilingCategoriesCounterCategory Property

Counter category is assigned when no category can be possitivelly assigned to a chemical.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string CounterCategory { get; }

Property Value

Type: String
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories.IsSorted Property

TbProfilingCategoriesIsSorted Property

If true the categoris are sorted by specific order and shoud not be re-sorted by the system alphabetically.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public bool IsSorted { get; }

Property Value

Type: Boolean
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategories Methods

The TbProfilingCategories type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbProfilingCategories Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode Class

Profiler category node definition.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.ProfilerTbProfilingCategoryNode

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbProfilingCategoryNode

The TbProfilingCategoryNode type exposes the following members.

Constructors
 | Name | Description
Public method | TbProfilingCategoryNode | Constructor for the profiler category node.
Top
Properties
 | Name | Description
Public property | ChildList | Child categories.
Public property | Color | Preferred color (to be used by the UI)
Public property | NodeCaption | Node caption. This will be used in the UI.
Public property | ParentCategory | Parent category NodeCaption
Public property | ToxProfilerDefinition | Relevant metadata table.
Public property | Version | Version of the profiling category.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode Constructor

Constructor for the profiler category node.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbProfilingCategoryNode(
    string nodeCaption,
    int version,
    Color color,
    string parentNodeCaption,
    IEnumerable<TbProfilingCategoryNode> childList,
    IEnumerable<TbToxicologicalProfilerInfoItem> toxProfilerDefinition = null
)

Parameters

nodeCaption
Type: SystemString
Node caption.
version
Type: SystemInt32
Version of the node.
color
Type: System.DrawingColor
Preferred color of the node (to be used by the UI).
parentNodeCaption
Type: SystemString
Caption of the node's parent.
childList
Type: System.Collections.GenericIEnumerable TbProfilingCategoryNode
Sub-nodes list.
toxProfilerDefinition (Optional)
Type: System.Collections.GenericIEnumerable TbToxicologicalProfilerInfoItem
Relevant metadata table.
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode Properties

The TbProfilingCategoryNode type exposes the following members.

Properties
 | Name | Description
Public property | ChildList | Child categories.
Public property | Color | Preferred color (to be used by the UI)
Public property | NodeCaption | Node caption. This will be used in the UI.
Public property | ParentCategory | Parent category NodeCaption
Public property | ToxProfilerDefinition | Relevant metadata table.
Public property | Version | Version of the profiling category.
Top
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.ChildList Property

TbProfilingCategoryNodeChildList Property

Child categories.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<TbProfilingCategoryNode> ChildList { get; }

Property Value

Type: IReadOnlyList TbProfilingCategoryNode
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.Color Property

TbProfilingCategoryNodeColor Property

Preferred color (to be used by the UI)

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Color Color { get; }

Property Value

Type: Color
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.NodeCaption Property

TbProfilingCategoryNodeNodeCaption Property

Node caption. This will be used in the UI.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string NodeCaption { get; }

Property Value

Type: String
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.ParentCategory Property

TbProfilingCategoryNodeParentCategory Property

Parent category NodeCaption

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string ParentCategory { get; }

Property Value

Type: String
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.ToxProfilerDefinition Property

TbProfilingCategoryNodeToxProfilerDefinition Property

Relevant metadata table.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<TbToxicologicalProfilerInfoItem> ToxProfilerDefinition { get; }

Property Value

Type: IReadOnlyList TbToxicologicalProfilerInfoItem
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode.Version Property

TbProfilingCategoryNodeVersion Property

Version of the profiling category.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public int Version { get; }

Property Value

Type: Int32
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbProfilingCategoryNode Methods

The TbProfilingCategoryNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbProfilingCategoryNode Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem Class

Relevant metadata table for a profiler category node.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.ProfilerTbToxicologicalProfilerInfoItem

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbToxicologicalProfilerInfoItem

The TbToxicologicalProfilerInfoItem type exposes the following members.

Constructors
 | Name | Description
Public method | TbToxicologicalProfilerInfoItem | Constructor for the info item.
Top
Properties
 | Name | Description
Public property | Children | Sub-nodes list.
Public property | Label | The metadata label e.g. Organ
Public property | Value | The metadata value e.g. Liver
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem Constructor

Constructor for the info item.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbToxicologicalProfilerInfoItem(
    string label,
    string value,
    IEnumerable<TbToxicologicalProfilerInfoItem> childs
)

Parameters

label
Type: SystemString
The metadata label e.g. Organ
value
Type: SystemString
The metadata value e.g. Liver
childs
Type: System.Collections.GenericIEnumerable TbToxicologicalProfilerInfoItem
Sub-nodes list.
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem Properties

The TbToxicologicalProfilerInfoItem type exposes the following members.

Properties
 | Name | Description
Public property | Children | Sub-nodes list.
Public property | Label | The metadata label e.g. Organ
Public property | Value | The metadata value e.g. Liver
Top
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem.Children Property

TbToxicologicalProfilerInfoItemChildren Property

Sub-nodes list.

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<TbToxicologicalProfilerInfoItem> Children { get; }

Property Value

Type: IReadOnlyList TbToxicologicalProfilerInfoItem
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem.Label Property

TbToxicologicalProfilerInfoItemLabel Property

The metadata label e.g. Organ

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Label { get; }

Property Value

Type: String
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem.Value Property

TbToxicologicalProfilerInfoItemValue Property

The metadata value e.g. Liver

Namespace: Toolbox.Docking.Api.Objects.Profiler
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Value { get; }

Property Value

Type: String
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


TbToxicologicalProfilerInfoItem Methods

The TbToxicologicalProfilerInfoItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbToxicologicalProfilerInfoItem Class
Toolbox.Docking.Api.Objects.Profiler Namespace


Toolbox.Docking.Api.Objects.Qsar Namespace

Classes
 | Class | Description
Public class | QsarDescriptorInfo | This class contains the most basic description for a QSAR descriptor.
Public class | TbQsarInfo | This class contains the most basic description for a QSAR.
Public class | TbQsarStatistics | Basic statistics for the QSAR model used for display reasons.
Interfaces
 | Interface | Description
Public interface | ITbPrediction | Toolbox prediction, product of a ITbQsar object.
Public interface | ITbQsar | Definition of a Toolbox QSAR, to be used for generating predictions
Public interface | ITbQsarFactory | Factory for constructing a Toolbox QSAR object.
Enumerations
 | Enumeration | Description
Public enumeration | QsarFlags | Toolbox calculator's metadata flags.


ITbPrediction Interface

Toolbox prediction, product of a ITbQsar object.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbPrediction

The ITbPrediction type exposes the following members.

Properties
 | Name | Description
Public property | Metadata | String and numeric descriptors of this prediction. Add here only prediction specific metadata. All QSAR metadata (IQsarFactory.Metadata) will be assigned from the system. For instance: String: Author, ContactDetails, Summary, MechanisticInterpretation, AdequacyOfPrediction, DataEliminationJustification Numeric: ConfidenceLevel, ReportedChemicalsCount CategoryDefinition, Hypothesis, EndpointsCovered, Purity, PhysicochemicalPropertiesJustification, StructureSimilarityJustification, MechanisticSimilarityJustification, SummaryJustificationFreeText
Public property | Value | Predicted value.
Public property | XDescriptorsValues | Values of X descriptors for chemical of this prediction.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


ITbPrediction Properties

The ITbPrediction type exposes the following members.

Properties
 | Name | Description
Public property | Metadata | String and numeric descriptors of this prediction. Add here only prediction specific metadata. All QSAR metadata (IQsarFactory.Metadata) will be assigned from the system. For instance: String: Author, ContactDetails, Summary, MechanisticInterpretation, AdequacyOfPrediction, DataEliminationJustification Numeric: ConfidenceLevel, ReportedChemicalsCount CategoryDefinition, Hypothesis, EndpointsCovered, Purity, PhysicochemicalPropertiesJustification, StructureSimilarityJustification, MechanisticSimilarityJustification, SummaryJustificationFreeText
Public property | Value | Predicted value.
Public property | XDescriptorsValues | Values of X descriptors for chemical of this prediction.
Top
See Also

Reference

ITbPrediction Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbPrediction.Metadata Property

ITbPredictionMetadata Property

String and numeric descriptors of this prediction.

Add here only prediction specific metadata. All QSAR metadata (IQsarFactory.Metadata) will be assigned from the system.

For instance:

String: Author, ContactDetails, Summary, MechanisticInterpretation, AdequacyOfPrediction, DataEliminationJustification

Numeric: ConfidenceLevel, ReportedChemicalsCount CategoryDefinition, Hypothesis, EndpointsCovered, Purity, PhysicochemicalPropertiesJustification, StructureSimilarityJustification, MechanisticSimilarityJustification, SummaryJustificationFreeText

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbMetadata Metadata { get; }

Property Value

Type: TbMetadata
See Also

Reference

ITbPrediction Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbPrediction.Value Property

ITbPredictionValue Property

Predicted value.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbData Value { get; }

Property Value

Type: TbData
See Also

Reference

ITbPrediction Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbPrediction.XDescriptorsValues Property

ITbPredictionXDescriptorsValues Property

Values of X descriptors for chemical of this prediction.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyDictionary<TbObjectId, TbData> XDescriptorsValues { get; }

Property Value

Type: IReadOnlyDictionary TbObjectId, TbData
See Also

Reference

ITbPrediction Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsar Interface

Definition of a Toolbox QSAR, to be used for generating predictions

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbQsar : ITbCalculator,
    ITbObject, IDisposable

The ITbQsar type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculate parameter value. (Inherited from ITbCalculator.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IsRelevantToChemical | Return false if for some reason cannot predict this chemical.
Public method | Predict | Creates a prediction with detailed information, which requires more time and resources.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsar Methods

The ITbQsar type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculate parameter value. (Inherited from ITbCalculator.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | IsRelevantToChemical | Return false if for some reason cannot predict this chemical.
Public method | Predict | Creates a prediction with detailed information, which requires more time and resources.
Top
See Also

Reference

ITbQsar Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsar.IsRelevantToChemical Method

ITbQsarIsRelevantToChemical Method

Return false if for some reason cannot predict this chemical.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool IsRelevantToChemical(
    ITbBasket chemical,
    out string reason
)

Parameters

chemical
Type: Toolbox.Docking.Api.ControlITbBasket
Chemical to be checked.
reason
Type: SystemString
Provides more information if the chemical is restricted.

Return Value

Type: Boolean
Return false if for some reason cannot predict this chemical.
See Also

Reference

ITbQsar Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsar.Predict Method

ITbQsarPredict Method

Creates a prediction with detailed information, which requires more time and resources.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbPrediction Predict(
    ITbBasket target
)

Parameters

target
Type: Toolbox.Docking.Api.ControlITbBasket
The Chemical for which to make a prediction.

Return Value

Type: ITbPrediction
Resulting Toolbox prediction.
See Also

Reference

ITbQsar Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory Interface

Factory for constructing a Toolbox QSAR object.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbQsarFactory : ITbObjectFactory

The ITbQsarFactory type exposes the following members.

Properties
 | Name | Description
Public property | AgreementInfo | Text which is shown to the user for the first time using the QSAR. Toolbox uses "remember my choice" for each agreement info
Public property | EndpointLocation | Rigid path in Toolbox endpoint tree
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | Metadata | Used to position QSAR at Endpoint tree. string Name { get; } Mandatory: Endpoint, Optional: Species, Duration, ExperimentalProtocol, Comments, DataQuality...
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | QmrfLocation | Location for the QMRF of the model. - in case this string is a valid HTTP or HTTPS URL it is opened in the browser TryCreate(String, UriKind, Uri) UriSchemeHttp UriSchemeHttps - else this string is interpreted as a file name and is searched in the config directory of the QSAR on the server.
Public property | QsarFlags | Description of the calculator.
Public property | ReportDisclaimer | Text to be added to the report when reporting a prediction with this QSAR.
Public property | ScaleDeclaration | This is the scale definition for the Unit that the calculator will return values in. Predict(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertible for system scales); for TbQualitativeScale the calculated unit must be member of this scale.
Public property | Statistics | Basic statistics about the model
Public property | XDescriptors | Used X descriptors. They can be calculators from Toolbox. Or just information for own calculated parameters (provide Guid.Empty)
Top
Methods
 | Name | Description
Public method | GetQsar | Returns an initialized, ready to use Toolbox QSAR.
Public method | GetTestSet | Returns the test set for the QSAR
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Public method | TrainingSet | Returns the training set for the QSAR
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory Properties

The ITbQsarFactory type exposes the following members.

Properties
 | Name | Description
Public property | AgreementInfo | Text which is shown to the user for the first time using the QSAR. Toolbox uses "remember my choice" for each agreement info
Public property | EndpointLocation | Rigid path in Toolbox endpoint tree
Public property | Flags | Provides the metadata describing the object's capabilities/constraints. (Inherited from ITbObjectFactory.)
Public property | Metadata | Used to position QSAR at Endpoint tree. string Name { get; } Mandatory: Endpoint, Optional: Species, Duration, ExperimentalProtocol, Comments, DataQuality...
Public property | ObjectAbout | Object containing the about information for the Toolbox object. This will be displayed on various places within the Toolbox Client's UI most often via an About button. (Inherited from ITbObjectFactory.)
Public property | ObjectId | Provides the object identification. This would be used throughout the application. For visualization and accounting purposes. (Inherited from ITbObjectFactory.)
Public property | QmrfLocation | Location for the QMRF of the model. - in case this string is a valid HTTP or HTTPS URL it is opened in the browser TryCreate(String, UriKind, Uri) UriSchemeHttp UriSchemeHttps - else this string is interpreted as a file name and is searched in the config directory of the QSAR on the server.
Public property | QsarFlags | Description of the calculator.
Public property | ReportDisclaimer | Text to be added to the report when reporting a prediction with this QSAR.
Public property | ScaleDeclaration | This is the scale definition for the Unit that the calculator will return values in. Predict(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertible for system scales); for TbQualitativeScale the calculated unit must be member of this scale.
Public property | Statistics | Basic statistics about the model
Public property | XDescriptors | Used X descriptors. They can be calculators from Toolbox. Or just information for own calculated parameters (provide Guid.Empty)
Top
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.AgreementInfo Property

ITbQsarFactoryAgreementInfo Property

Text which is shown to the user for the first time using the QSAR. Toolbox uses "remember my choice" for each agreement info

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string AgreementInfo { get; }

Property Value

Type: String
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.EndpointLocation Property

ITbQsarFactoryEndpointLocation Property

Rigid path in Toolbox endpoint tree

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<string> EndpointLocation { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.Metadata Property

ITbQsarFactoryMetadata Property

Used to position QSAR at Endpoint tree. string Name { get; } Mandatory: Endpoint, Optional: Species, Duration, ExperimentalProtocol, Comments, DataQuality...

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbMetadata Metadata { get; }

Property Value

Type: TbMetadata
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.QmrfLocation Property

ITbQsarFactoryQmrfLocation Property

Location for the QMRF of the model. - in case this string is a valid HTTP or HTTPS URL it is opened in the browser TryCreate(String, UriKind, Uri) UriSchemeHttp UriSchemeHttps - else this string is interpreted as a file name and is searched in the config directory of the QSAR on the server.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string QmrfLocation { get; }

Property Value

Type: String
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.QsarFlags Property

ITbQsarFactoryQsarFlags Property

Description of the calculator.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
QsarFlags QsarFlags { get; }

Property Value

Type: QsarFlags
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.ReportDisclaimer Property

ITbQsarFactoryReportDisclaimer Property

Text to be added to the report when reporting a prediction with this QSAR.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ReportDisclaimer { get; }

Property Value

Type: String
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.ScaleDeclaration Property

ITbQsarFactoryScaleDeclaration Property

This is the scale definition for the Unit that the calculator will return values in. Predict(ITbBasket) shall return all values in a single, consistent unit: for TbRatioScale the same as BaseUnit of this scale (or convertible for system scales); for TbQualitativeScale the calculated unit must be member of this scale.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbScale ScaleDeclaration { get; }

Property Value

Type: TbScale
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.Statistics Property

ITbQsarFactoryStatistics Property

Basic statistics about the model

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbQsarStatistics Statistics { get; }

Property Value

Type: TbQsarStatistics
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.XDescriptors Property

ITbQsarFactoryXDescriptors Property

Used X descriptors. They can be calculators from Toolbox. Or just information for own calculated parameters (provide Guid.Empty)

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<QsarDescriptorInfo> XDescriptors { get; }

Property Value

Type: IReadOnlyList QsarDescriptorInfo
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory Methods

The ITbQsarFactory type exposes the following members.

Methods
 | Name | Description
Public method | GetQsar | Returns an initialized, ready to use Toolbox QSAR.
Public method | GetTestSet | Returns the test set for the QSAR
Public method | InitFactory | Initializes the factory. The method should be called once. (Inherited from ITbObjectFactory.)
Public method | TrainingSet | Returns the training set for the QSAR
Top
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.GetQsar Method

ITbQsarFactoryGetQsar Method

Returns an initialized, ready to use Toolbox QSAR.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbQsar GetQsar(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Task responsible for the object initialization

Return Value

Type: ITbQsar
The initialized Toolbox QSAR
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.GetTestSet Method

ITbQsarFactoryGetTestSet Method

Returns the test set for the QSAR

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<ChemicalWithData> GetTestSet(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Since the loading of a test set may be a slow process a task is supplied to be used for progress notification

Return Value

Type: IReadOnlyList ChemicalWithData
The QSAR test set.
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


ITbQsarFactory.TrainingSet Method

ITbQsarFactoryTrainingSet Method

Returns the training set for the QSAR

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<ChemicalWithData> TrainingSet(
    ITbWorkTask task
)

Parameters

task
Type: Toolbox.Docking.Api.ControlITbWorkTask
Since the loading of a training set may be a slow process a task is supplied to be used for progress notification

Return Value

Type: IReadOnlyList ChemicalWithData
The QSAR training set.
See Also

Reference

ITbQsarFactory Interface
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo Class

This class contains the most basic description for a QSAR descriptor.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.QsarQsarDescriptorInfo

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class QsarDescriptorInfo

The QsarDescriptorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | QsarDescriptorInfo | Constructor for the QsarDescriptorInfo object.
Top
Properties
 | Name | Description
Public property | Descriptor | The Toolbox object responsible for the calculation of the descriptor.
Public property | DescriptorUnit | The unit for the descriptor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo Constructor

Constructor for the QsarDescriptorInfo object.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public QsarDescriptorInfo(
    TbObjectId descriptor,
    TbScale descriptorUnit
)

Parameters

descriptor
Type: Toolbox.Docking.Api.ObjectsTbObjectId
The Toolbox object responsible for the calculation of the descriptor.
descriptorUnit
Type: Toolbox.Docking.Api.UnitsTbScale
The unit for the descriptor.
See Also

Reference

QsarDescriptorInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo Properties

The QsarDescriptorInfo type exposes the following members.

Properties
 | Name | Description
Public property | Descriptor | The Toolbox object responsible for the calculation of the descriptor.
Public property | DescriptorUnit | The unit for the descriptor.
Top
See Also

Reference

QsarDescriptorInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo.Descriptor Property

QsarDescriptorInfoDescriptor Property

The Toolbox object responsible for the calculation of the descriptor.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbObjectId Descriptor { get; }

Property Value

Type: TbObjectId
See Also

Reference

QsarDescriptorInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo.DescriptorUnit Property

QsarDescriptorInfoDescriptorUnit Property

The unit for the descriptor.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbScale DescriptorUnit { get; }

Property Value

Type: TbScale
See Also

Reference

QsarDescriptorInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarDescriptorInfo Methods

The QsarDescriptorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QsarDescriptorInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


QsarFlags Enumeration

Toolbox calculator's metadata flags.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum QsarFlags
Members
Member name | Value | Description
None | 0 | Empty QSAR flag.
SlowCalculation | 1 | The calculation of QSAR prediction is slow.
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo Class

This class contains the most basic description for a QSAR.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.ObjectsTbObjectInfo
Toolbox.Docking.Api.Objects.QsarTbQsarInfo

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbQsarInfo : TbObjectInfo

The TbQsarInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TbQsarInfo | Constructor for the QSAR info object.
Top
Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Unit | The Unit the predictions of the QSAR are in.
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo Constructor

Constructor for the QSAR info object.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbQsarInfo(
    TbObjectInfoFlags objFlags,
    TbUnit unit
)

Parameters

objFlags
Type: Toolbox.Docking.Api.ObjectsTbObjectInfoFlags
Object information flags
unit
Type: Toolbox.Docking.Api.UnitsTbUnit
The Unit the predictions of the QSAR are in.
See Also

Reference

TbQsarInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo Properties

The TbQsarInfo type exposes the following members.

Properties
 | Name | Description
Public property | ObjectFlags | Access to object's flags (Inherited from TbObjectInfo.)
Top
See Also

Reference

TbQsarInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo Methods

The TbQsarInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbQsarInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo Fields

The TbQsarInfo type exposes the following members.

Fields
 | Name | Description
Public field | Unit | The Unit the predictions of the QSAR are in.
Top
See Also

Reference

TbQsarInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarInfo.Unit Field

TbQsarInfoUnit Field

The Unit the predictions of the QSAR are in.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public readonly TbUnit Unit

Field Value

Type: TbUnit
See Also

Reference

TbQsarInfo Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Class

Basic statistics for the QSAR model used for display reasons.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.Objects.QsarTbQsarStatistics

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbQsarStatistics

The TbQsarStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | TbQsarStatistics(NullableInt32, NullableInt32, NullableInt32, NullableInt32) | The constructor
Public method | TbQsarStatistics(NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32) | Initializes a new instance of the TbQsarStatistics class
Top
Properties
 | Name | Description
Public property | ProprietaryTestSetCount | The number of proprietary chemicals in the test set. If null the number is unknown.
Public property | ProprietaryTrainingSetCount | The number of proprietary chemicals in the training set. If null the number is unknown.
Public property | TestSetCount | The number of chemicals used for the test set. If null the number is unknown.
Public property | TestSetDataCount | The number of data of the test set. If null the number is unknown.
Public property | TrainingSetCount | The number of chemicals used for the training set. If null the number is unknown.
Public property | TrainingSetDataCount | The number of data of the training set. If null the number is unknown.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Constructor

Overload List
 | Name | Description
Public method | TbQsarStatistics(NullableInt32, NullableInt32, NullableInt32, NullableInt32) | The constructor
Public method | TbQsarStatistics(NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32) | Initializes a new instance of the TbQsarStatistics class
Top
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Constructor (Nullable(Int32), Nullable(Int32), Nullable(Int32), Nullable(Int32))

TbQsarStatistics Constructor (NullableInt32, NullableInt32, NullableInt32, NullableInt32)

The constructor

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbQsarStatistics(
    Nullable<int> trainingSetCount,
    Nullable<int> trainingSetDataCount,
    Nullable<int> testSetCount,
    Nullable<int> testSetDataCount
)

Parameters

trainingSetCount
Type: SystemNullable Int32
The number of chemicals used for the training set. If null the number is unknown.
trainingSetDataCount
Type: SystemNullable Int32
The number of data of the training set. If null the number is unknown.
testSetCount
Type: SystemNullable Int32
The number of chemicals used for the test set. If null the number is unknown.
testSetDataCount
Type: SystemNullable Int32
The number of data of the test set. If null the number is unknown.
See Also

Reference

TbQsarStatistics Class
TbQsarStatistics Overload
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Constructor (Nullable(Int32), Nullable(Int32), Nullable(Int32), Nullable(Int32), Nullable(Int32), Nullable(Int32))

TbQsarStatistics Constructor (NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32, NullableInt32)

Initializes a new instance of the TbQsarStatistics class

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbQsarStatistics(
    Nullable<int> trainingSetCount,
    Nullable<int> proprietaryTrainingSetCount,
    Nullable<int> trainingSetDataCount,
    Nullable<int> testSetCount,
    Nullable<int> proprietaryTestSetCount,
    Nullable<int> testSetDataCount
)

Parameters

trainingSetCount
Type: SystemNullable Int32
The number of chemicals used for the training set. If null the number is unknown.
proprietaryTrainingSetCount
Type: SystemNullable Int32
The number of proprietary chemicals in the training set. If null the number is unknown.
trainingSetDataCount
Type: SystemNullable Int32
The number of data of the training set. If null the number is unknown.
testSetCount
Type: SystemNullable Int32
The number of chemicals used for the test set. If null the number is unknown.
proprietaryTestSetCount
Type: SystemNullable Int32
The number of proprietary chemicals in the test set. If null the number is unknown.
testSetDataCount
Type: SystemNullable Int32
The number of data of the test set. If null the number is unknown.
See Also

Reference

TbQsarStatistics Class
TbQsarStatistics Overload
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Properties

The TbQsarStatistics type exposes the following members.

Properties
 | Name | Description
Public property | ProprietaryTestSetCount | The number of proprietary chemicals in the test set. If null the number is unknown.
Public property | ProprietaryTrainingSetCount | The number of proprietary chemicals in the training set. If null the number is unknown.
Public property | TestSetCount | The number of chemicals used for the test set. If null the number is unknown.
Public property | TestSetDataCount | The number of data of the test set. If null the number is unknown.
Public property | TrainingSetCount | The number of chemicals used for the training set. If null the number is unknown.
Public property | TrainingSetDataCount | The number of data of the training set. If null the number is unknown.
Top
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.ProprietaryTestSetCount Property

TbQsarStatisticsProprietaryTestSetCount Property

The number of proprietary chemicals in the test set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> ProprietaryTestSetCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.ProprietaryTrainingSetCount Property

TbQsarStatisticsProprietaryTrainingSetCount Property

The number of proprietary chemicals in the training set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> ProprietaryTrainingSetCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.TestSetCount Property

TbQsarStatisticsTestSetCount Property

The number of chemicals used for the test set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> TestSetCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.TestSetDataCount Property

TbQsarStatisticsTestSetDataCount Property

The number of data of the test set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> TestSetDataCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.TrainingSetCount Property

TbQsarStatisticsTrainingSetCount Property

The number of chemicals used for the training set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> TrainingSetCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics.TrainingSetDataCount Property

TbQsarStatisticsTrainingSetDataCount Property

The number of data of the training set. If null the number is unknown.

Namespace: Toolbox.Docking.Api.Objects.Qsar
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Nullable<int> TrainingSetDataCount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


TbQsarStatistics Methods

The TbQsarStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbQsarStatistics Class
Toolbox.Docking.Api.Objects.Qsar Namespace


Toolbox.Docking.Api.Units Namespace

Classes
 | Class | Description
Public class | TbNominalScale | This class represents a Nominal type categorical scale.
Public class | TbOrdinalScale | This class represents a Ordinal type categorical scale. The order of the category members of an Ordinal, as opposed to Nominal, scale have significance.
Public class | TbQualitativeScale | Base type for the Nominal and Ordinal scales.
Public class | TbRatioScale | This class represents a Ratio type scale.
Public class | TbScale | Base class representing a Toolbox scale.
Public class | TbUnit | Data unit representation.


TbNominalScale Class

This class represents a Nominal type categorical scale.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbScale
Toolbox.Docking.Api.UnitsTbQualitativeScale
Toolbox.Docking.Api.UnitsTbNominalScale

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbNominalScale : TbQualitativeScale

The TbNominalScale type exposes the following members.

Constructors
 | Name | Description
Public method | TbNominalScale | Constructor for the Nominal type categorical scale.
Top
Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members. (Inherited from TbQualitativeScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbNominalScale Constructor

Constructor for the Nominal type categorical scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbNominalScale(
    string name,
    string familyGroup,
    Guid identity,
    IReadOnlyList<string> labels
)

Parameters

name
Type: SystemString
Name for the scale.
familyGroup
Type: SystemString
Family group for the scale.
identity
Type: SystemGuid
The unique persistent identifier for the scale.
labels
Type: System.Collections.GenericIReadOnlyList String
The category members.
See Also

Reference

TbNominalScale Class
Toolbox.Docking.Api.Units Namespace


TbNominalScale Properties

The TbNominalScale type exposes the following members.

Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members. (Inherited from TbQualitativeScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
See Also

Reference

TbNominalScale Class
Toolbox.Docking.Api.Units Namespace


TbNominalScale Methods

The TbNominalScale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbNominalScale Class
Toolbox.Docking.Api.Units Namespace


TbOrdinalScale Class

This class represents a Ordinal type categorical scale. The order of the category members of an Ordinal, as opposed to Nominal, scale have significance.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbScale
Toolbox.Docking.Api.UnitsTbQualitativeScale
Toolbox.Docking.Api.UnitsTbOrdinalScale

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbOrdinalScale : TbQualitativeScale

The TbOrdinalScale type exposes the following members.

Constructors
 | Name | Description
Public method | TbOrdinalScale | Constructor for the Ordinal type categorical scale.
Top
Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members. (Inherited from TbQualitativeScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbOrdinalScale Constructor

Constructor for the Ordinal type categorical scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbOrdinalScale(
    string name,
    string familyGroup,
    Guid identity,
    IReadOnlyList<string> labels
)

Parameters

name
Type: SystemString
Name for the scale.
familyGroup
Type: SystemString
Family group for the scale.
identity
Type: SystemGuid
The unique persistent identifier for the scale.
labels
Type: System.Collections.GenericIReadOnlyList String
The category members.
See Also

Reference

TbOrdinalScale Class
Toolbox.Docking.Api.Units Namespace


TbOrdinalScale Properties

The TbOrdinalScale type exposes the following members.

Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members. (Inherited from TbQualitativeScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
See Also

Reference

TbOrdinalScale Class
Toolbox.Docking.Api.Units Namespace


TbOrdinalScale Methods

The TbOrdinalScale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbOrdinalScale Class
Toolbox.Docking.Api.Units Namespace


TbQualitativeScale Class

Base type for the Nominal and Ordinal scales.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbScale
Toolbox.Docking.Api.UnitsTbQualitativeScale
Toolbox.Docking.Api.UnitsTbNominalScale
Toolbox.Docking.Api.UnitsTbOrdinalScale

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public abstract class TbQualitativeScale : TbScale

The TbQualitativeScale type exposes the following members.

Constructors
 | Name | Description
Protected method | TbQualitativeScale | Base constructor for a Nominal/Ordinal scale objects.
Top
Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members.
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbQualitativeScale Constructor

Base constructor for a Nominal/Ordinal scale objects.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected TbQualitativeScale(
    string name,
    string familyGroup,
    Guid identity,
    IReadOnlyList<string> labels
)

Parameters

name
Type: SystemString
Name for the scale.
familyGroup
Type: SystemString
Family group for the scale.
identity
Type: SystemGuid
The unique persistent identifier for the scale.
labels
Type: System.Collections.GenericIReadOnlyList String
The category members.
See Also

Reference

TbQualitativeScale Class
Toolbox.Docking.Api.Units Namespace


TbQualitativeScale Properties

The TbQualitativeScale type exposes the following members.

Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Labels | The list of category members.
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
See Also

Reference

TbQualitativeScale Class
Toolbox.Docking.Api.Units Namespace


TbQualitativeScale.Labels Property

TbQualitativeScaleLabels Property

The list of category members.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public IReadOnlyList<string> Labels { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

TbQualitativeScale Class
Toolbox.Docking.Api.Units Namespace


TbQualitativeScale Methods

The TbQualitativeScale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbQualitativeScale Class
Toolbox.Docking.Api.Units Namespace


TbRatioScale Class

This class represents a Ratio type scale.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbScale
Toolbox.Docking.Api.UnitsTbRatioScale

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbRatioScale : TbScale

The TbRatioScale type exposes the following members.

Constructors
 | Name | Description
Public method | TbRatioScale(TbRatioScale, String) | Constructor for the ratio scale object.
Public method | TbRatioScale(String, String, Guid, String) | Constructor for the ratio scale object.
Top
Properties
 | Name | Description
Public property | BaseUnit | Base unit for the scale.
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbRatioScale Constructor

Overload List
 | Name | Description
Public method | TbRatioScale(TbRatioScale, String) | Constructor for the ratio scale object.
Public method | TbRatioScale(String, String, Guid, String) | Constructor for the ratio scale object.
Top
See Also

Reference

TbRatioScale Class
Toolbox.Docking.Api.Units Namespace


TbRatioScale Constructor (TbRatioScale, String)

Constructor for the ratio scale object.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbRatioScale(
    TbRatioScale fromScale,
    string baseUnit
)

Parameters

fromScale
Type: Toolbox.Docking.Api.UnitsTbRatioScale
The existing scale
baseUnit
Type: SystemString
Predefined base unit
See Also

Reference

TbRatioScale Class
TbRatioScale Overload
Toolbox.Docking.Api.Units Namespace


TbRatioScale Constructor (String, String, Guid, String)

Constructor for the ratio scale object.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbRatioScale(
    string name,
    string familyGroup,
    Guid identity,
    string baseUnit
)

Parameters

name
Type: SystemString
Name for the scale.
familyGroup
Type: SystemString
Family group for the scale.
identity
Type: SystemGuid
The unique persistent identifier for the scale.
baseUnit
Type: SystemString
Base unit for the ratio scale.
See Also

Reference

TbRatioScale Class
TbRatioScale Overload
Toolbox.Docking.Api.Units Namespace


TbRatioScale Properties

The TbRatioScale type exposes the following members.

Properties
 | Name | Description
Public property | BaseUnit | Base unit for the scale.
Public property | FamilyGroup | Family group for the scale. (Inherited from TbScale.)
Public property | Identity | The unique persistent identifier for the scale. (Inherited from TbScale.)
Public property | Name | Name for the scale. (Inherited from TbScale.)
Top
See Also

Reference

TbRatioScale Class
Toolbox.Docking.Api.Units Namespace


TbRatioScale.BaseUnit Property

TbRatioScaleBaseUnit Property

Base unit for the scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string BaseUnit { get; }

Property Value

Type: String
See Also

Reference

TbRatioScale Class
Toolbox.Docking.Api.Units Namespace


TbRatioScale Methods

The TbRatioScale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbRatioScale Class
Toolbox.Docking.Api.Units Namespace


TbScale Class

Base class representing a Toolbox scale.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbScale
Toolbox.Docking.Api.UnitsTbQualitativeScale
Toolbox.Docking.Api.UnitsTbRatioScale

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public abstract class TbScale

The TbScale type exposes the following members.

Constructors
 | Name | Description
Protected method | TbScale | Base constructor for a Toolbox scale.
Top
Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale.
Public property | Identity | The unique persistent identifier for the scale.
Public property | Name | Name for the scale.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AdministeredDose_AmountOfSubstance | Predefined scale for Administered dose amount of substance. Base unit mol/g/s.
AdministeredDose_mass | Predefined scale for Administered dose mass. Base unit g/g/s.
AmountOfSubstance | Predefined scale for Amount of substance. Base unit mol.
Area | Predefined scale for Area. Base unit m².
Bioaccumulation | Predefined scale for Bioaccumulation. Base unit m³/g.
BiodegradabilityCategories | Predefined ordinal scale for Biodegradability (categories). Family: Biodegradation. Categories: Ready, Not ready
BiodegradabilityPercent | Predefined ratio scale for Biodegradability in %. Family: Biodegradation
CarcinogenicityI_ISSCAN | Predefined ordinal scale for Carcinogenicity I (ISSCAN). Family: Carcinogenicity. Categories: Positive, Equivocal, Negative
ChromosomeAberrationI | Predefined ordinal scale for Chromosome aberration I. Family: Mutagenicity. Categories: Positive, Negative
ConcentrationInBody_mass | Predefined scale for Concentration in body mass. Base unit g/g.
ConcentrationInBody_mole | Predefined scale for Concentration in body mole. Base unit mol/g.
DartToxicityOrdinal | Predefined ordinal scale for DART toxicity (ordinal). Family: Developmental. Categories: Positive, Undefined, Negative
Distance | Predefined scale for Distance. Base unit m.
DoseRate_amountOfSubstance | Predefined scale for Dose rate amount of substance. Base unit mol/s.
DoseRate_mass | Predefined scale for Dose rate mass. Base unit g/s.
EmptyRatioScale | Predefined scale for an empty ratio unit. Like ratio. It has the GUID of NoFamily.ContinuousDataType
EstrogenReceptorBinding_DanishEpa | Predefined ordinal scale for Estrogen Receptor Binding (Danish EPA). Family: Estrogen. Categories: Positive, Equivocal, Negative
GeneMutationI | Predefined ordinal scale for Gene mutation I. Family: Mutagenicity. Categories: Positive, Equivocal, Negative
Mass | Predefined scale for Mass. Base unit g.
MassConcentration | Predefined scale for Mass concentration. Base unit g/m³.
MassFraction | Predefined scale for Mass fraction. Base unit g/g.
Molality | Predefined scale for Molality. Base unit mol/g.
MolarConcentration | Predefined scale for Molar concentration. Base unit mol/m³.
MoleFraction | Predefined scale for Mole fraction. Base unit mol/mol.
Pressure | Predefined scale for Pressure. Base unit Pa.
PressurePerMole | Predefined scale for Pressure per mole. Base unit Pa-m3/mole.
RespiratorySensitizationI_Ecetoc | Predefined ordinal scale for Respiratory sensitization I (ECETOC). Family: Respiratory. Categories: Positive, Negative
SevereSkinIrritation_DanishEpa | Predefined ordinal scale for Severe skin irritation (Danish EPA). Family: Skin Irritation/Corroson. Categories: Positive, Equivocal, Negative
SkinSensitisationII_Ecetoc | Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative
SkinSensitisationIII_LJMU | Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative
SpecificVolume | Predefined scale for Specific volume. Base unit m³/g.
Speed | Predefined scale for Speed. Base unit m/s.
Temperature | Predefined scale for Temperature. Base unit °C.
Time | Predefined scale for Time. Base unit s.
Volume | Predefined scale for Volume. Base unit m³.
VolumeConcentration | Predefined scale for Volume concentration. Base unit m³/m³.
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbScale Constructor

Base constructor for a Toolbox scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
protected TbScale(
    string name,
    string familyGroup,
    Guid identity
)

Parameters

name
Type: SystemString
Name for the scale.
familyGroup
Type: SystemString
Family group for the scale.
identity
Type: SystemGuid
The unique persistent identifier for the scale.
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale Properties

The TbScale type exposes the following members.

Properties
 | Name | Description
Public property | FamilyGroup | Family group for the scale.
Public property | Identity | The unique persistent identifier for the scale.
Public property | Name | Name for the scale.
Top
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.FamilyGroup Property

TbScaleFamilyGroup Property

Family group for the scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string FamilyGroup { get; }

Property Value

Type: String
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Identity Property

TbScaleIdentity Property

The unique persistent identifier for the scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public Guid Identity { get; }

Property Value

Type: Guid
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Name Property

TbScaleName Property

Name for the scale.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale Methods

The TbScale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale Fields

The TbScale type exposes the following members.

Fields
Name | Description
AdministeredDose_AmountOfSubstance | Predefined scale for Administered dose amount of substance. Base unit mol/g/s.
AdministeredDose_mass | Predefined scale for Administered dose mass. Base unit g/g/s.
AmountOfSubstance | Predefined scale for Amount of substance. Base unit mol.
Area | Predefined scale for Area. Base unit m².
Bioaccumulation | Predefined scale for Bioaccumulation. Base unit m³/g.
BiodegradabilityCategories | Predefined ordinal scale for Biodegradability (categories). Family: Biodegradation. Categories: Ready, Not ready
BiodegradabilityPercent | Predefined ratio scale for Biodegradability in %. Family: Biodegradation
CarcinogenicityI_ISSCAN | Predefined ordinal scale for Carcinogenicity I (ISSCAN). Family: Carcinogenicity. Categories: Positive, Equivocal, Negative
ChromosomeAberrationI | Predefined ordinal scale for Chromosome aberration I. Family: Mutagenicity. Categories: Positive, Negative
ConcentrationInBody_mass | Predefined scale for Concentration in body mass. Base unit g/g.
ConcentrationInBody_mole | Predefined scale for Concentration in body mole. Base unit mol/g.
DartToxicityOrdinal | Predefined ordinal scale for DART toxicity (ordinal). Family: Developmental. Categories: Positive, Undefined, Negative
Distance | Predefined scale for Distance. Base unit m.
DoseRate_amountOfSubstance | Predefined scale for Dose rate amount of substance. Base unit mol/s.
DoseRate_mass | Predefined scale for Dose rate mass. Base unit g/s.
EmptyRatioScale | Predefined scale for an empty ratio unit. Like ratio. It has the GUID of NoFamily.ContinuousDataType
EstrogenReceptorBinding_DanishEpa | Predefined ordinal scale for Estrogen Receptor Binding (Danish EPA). Family: Estrogen. Categories: Positive, Equivocal, Negative
GeneMutationI | Predefined ordinal scale for Gene mutation I. Family: Mutagenicity. Categories: Positive, Equivocal, Negative
Mass | Predefined scale for Mass. Base unit g.
MassConcentration | Predefined scale for Mass concentration. Base unit g/m³.
MassFraction | Predefined scale for Mass fraction. Base unit g/g.
Molality | Predefined scale for Molality. Base unit mol/g.
MolarConcentration | Predefined scale for Molar concentration. Base unit mol/m³.
MoleFraction | Predefined scale for Mole fraction. Base unit mol/mol.
Pressure | Predefined scale for Pressure. Base unit Pa.
PressurePerMole | Predefined scale for Pressure per mole. Base unit Pa-m3/mole.
RespiratorySensitizationI_Ecetoc | Predefined ordinal scale for Respiratory sensitization I (ECETOC). Family: Respiratory. Categories: Positive, Negative
SevereSkinIrritation_DanishEpa | Predefined ordinal scale for Severe skin irritation (Danish EPA). Family: Skin Irritation/Corroson. Categories: Positive, Equivocal, Negative
SkinSensitisationII_Ecetoc | Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative
SkinSensitisationIII_LJMU | Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative
SpecificVolume | Predefined scale for Specific volume. Base unit m³/g.
Speed | Predefined scale for Speed. Base unit m/s.
Temperature | Predefined scale for Temperature. Base unit °C.
Time | Predefined scale for Time. Base unit s.
Volume | Predefined scale for Volume. Base unit m³.
VolumeConcentration | Predefined scale for Volume concentration. Base unit m³/m³.
Top
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.AdministeredDose_AmountOfSubstance Field

TbScaleAdministeredDose_AmountOfSubstance Field

Predefined scale for Administered dose amount of substance. Base unit mol/g/s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale AdministeredDose_AmountOfSubstance

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.AdministeredDose_mass Field

TbScaleAdministeredDose_mass Field

Predefined scale for Administered dose mass. Base unit g/g/s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale AdministeredDose_mass

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.AmountOfSubstance Field

TbScaleAmountOfSubstance Field

Predefined scale for Amount of substance. Base unit mol.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale AmountOfSubstance

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Area Field

TbScaleArea Field

Predefined scale for Area. Base unit m².

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Area

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Bioaccumulation Field

TbScaleBioaccumulation Field

Predefined scale for Bioaccumulation. Base unit m³/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Bioaccumulation

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.BiodegradabilityCategories Field

TbScaleBiodegradabilityCategories Field

Predefined ordinal scale for Biodegradability (categories). Family: Biodegradation. Categories: Ready, Not ready

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale BiodegradabilityCategories

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.BiodegradabilityPercent Field

TbScaleBiodegradabilityPercent Field

Predefined ratio scale for Biodegradability in %. Family: Biodegradation

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale BiodegradabilityPercent

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.CarcinogenicityI_ISSCAN Field

TbScaleCarcinogenicityI_ISSCAN Field

Predefined ordinal scale for Carcinogenicity I (ISSCAN). Family: Carcinogenicity. Categories: Positive, Equivocal, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale CarcinogenicityI_ISSCAN

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.ChromosomeAberrationI Field

TbScaleChromosomeAberrationI Field

Predefined ordinal scale for Chromosome aberration I. Family: Mutagenicity. Categories: Positive, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale ChromosomeAberrationI

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.ConcentrationInBody_mass Field

TbScaleConcentrationInBody_mass Field

Predefined scale for Concentration in body mass. Base unit g/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale ConcentrationInBody_mass

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.ConcentrationInBody_mole Field

TbScaleConcentrationInBody_mole Field

Predefined scale for Concentration in body mole. Base unit mol/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale ConcentrationInBody_mole

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.DartToxicityOrdinal Field

TbScaleDartToxicityOrdinal Field

Predefined ordinal scale for DART toxicity (ordinal). Family: Developmental. Categories: Positive, Undefined, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale DartToxicityOrdinal

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Distance Field

TbScaleDistance Field

Predefined scale for Distance. Base unit m.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Distance

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.DoseRate_amountOfSubstance Field

TbScaleDoseRate_amountOfSubstance Field

Predefined scale for Dose rate amount of substance. Base unit mol/s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale DoseRate_amountOfSubstance

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.DoseRate_mass Field

TbScaleDoseRate_mass Field

Predefined scale for Dose rate mass. Base unit g/s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale DoseRate_mass

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.EmptyRatioScale Field

TbScaleEmptyRatioScale Field

Predefined scale for an empty ratio unit. Like ratio. It has the GUID of NoFamily.ContinuousDataType

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale EmptyRatioScale

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.EstrogenReceptorBinding_DanishEpa Field

TbScaleEstrogenReceptorBinding_DanishEpa Field

Predefined ordinal scale for Estrogen Receptor Binding (Danish EPA). Family: Estrogen. Categories: Positive, Equivocal, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale EstrogenReceptorBinding_DanishEpa

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.GeneMutationI Field

TbScaleGeneMutationI Field

Predefined ordinal scale for Gene mutation I. Family: Mutagenicity. Categories: Positive, Equivocal, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale GeneMutationI

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Mass Field

TbScaleMass Field

Predefined scale for Mass. Base unit g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Mass

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.MassConcentration Field

TbScaleMassConcentration Field

Predefined scale for Mass concentration. Base unit g/m³.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale MassConcentration

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.MassFraction Field

TbScaleMassFraction Field

Predefined scale for Mass fraction. Base unit g/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale MassFraction

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Molality Field

TbScaleMolality Field

Predefined scale for Molality. Base unit mol/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Molality

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.MolarConcentration Field

TbScaleMolarConcentration Field

Predefined scale for Molar concentration. Base unit mol/m³.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale MolarConcentration

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.MoleFraction Field

TbScaleMoleFraction Field

Predefined scale for Mole fraction. Base unit mol/mol.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale MoleFraction

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Pressure Field

TbScalePressure Field

Predefined scale for Pressure. Base unit Pa.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Pressure

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.PressurePerMole Field

TbScalePressurePerMole Field

Predefined scale for Pressure per mole. Base unit Pa-m3/mole.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale PressurePerMole

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.RespiratorySensitizationI_Ecetoc Field

TbScaleRespiratorySensitizationI_Ecetoc Field

Predefined ordinal scale for Respiratory sensitization I (ECETOC). Family: Respiratory. Categories: Positive, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale RespiratorySensitizationI_Ecetoc

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.SevereSkinIrritation_DanishEpa Field

TbScaleSevereSkinIrritation_DanishEpa Field

Predefined ordinal scale for Severe skin irritation (Danish EPA). Family: Skin Irritation/Corroson. Categories: Positive, Equivocal, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale SevereSkinIrritation_DanishEpa

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.SkinSensitisationII_Ecetoc Field

TbScaleSkinSensitisationII_Ecetoc Field

Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale SkinSensitisationII_Ecetoc

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.SkinSensitisationIII_LJMU Field

TbScaleSkinSensitisationIII_LJMU Field

Predefined ordinal scale for Skin sensitisation II (ECETOC). Family: Skin. Categories: Positive, Negative

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbOrdinalScale SkinSensitisationIII_LJMU

Field Value

Type: TbOrdinalScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.SpecificVolume Field

TbScaleSpecificVolume Field

Predefined scale for Specific volume. Base unit m³/g.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale SpecificVolume

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Speed Field

TbScaleSpeed Field

Predefined scale for Speed. Base unit m/s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Speed

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Temperature Field

TbScaleTemperature Field

Predefined scale for Temperature. Base unit °C.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Temperature

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Time Field

TbScaleTime Field

Predefined scale for Time. Base unit s.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Time

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.Volume Field

TbScaleVolume Field

Predefined scale for Volume. Base unit m³.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale Volume

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbScale.VolumeConcentration Field

TbScaleVolumeConcentration Field

Predefined scale for Volume concentration. Base unit m³/m³.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public static readonly TbRatioScale VolumeConcentration

Field Value

Type: TbRatioScale
See Also

Reference

TbScale Class
Toolbox.Docking.Api.Units Namespace


TbUnit Class

Data unit representation.
Inheritance Hierarchy
SystemObject
Toolbox.Docking.Api.UnitsTbUnit

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TbUnit

The TbUnit type exposes the following members.

Constructors
 | Name | Description
Public method | TbUnit | Constructor for a Toolbox unit object.
Top
Properties
 | Name | Description
Public property | FamilyName | The name of the Family the unit belongs to.
Public property | Unit | The name of the Toolbox unit.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Toolbox.Docking.Api.Units Namespace


TbUnit Constructor

Constructor for a Toolbox unit object.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public TbUnit(
    string familyName,
    string unit
)

Parameters

familyName
Type: SystemString
The family name for the unit e.g. Mass.
unit
Type: SystemString
The unit name e.g. kg.
See Also

Reference

TbUnit Class
Toolbox.Docking.Api.Units Namespace


TbUnit Properties

The TbUnit type exposes the following members.

Properties
 | Name | Description
Public property | FamilyName | The name of the Family the unit belongs to.
Public property | Unit | The name of the Toolbox unit.
Top
See Also

Reference

TbUnit Class
Toolbox.Docking.Api.Units Namespace


TbUnit.FamilyName Property

TbUnitFamilyName Property

The name of the Family the unit belongs to.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string FamilyName { get; }

Property Value

Type: String
See Also

Reference

TbUnit Class
Toolbox.Docking.Api.Units Namespace


TbUnit.Unit Property

TbUnitUnit Property

The name of the Toolbox unit.

Namespace: Toolbox.Docking.Api.Units
Assembly: Toolbox.Docking.Api (in Toolbox.Docking.Api.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public string Unit { get; }

Property Value

Type: String
See Also

Reference

TbUnit Class
Toolbox.Docking.Api.Units Namespace


TbUnit Methods

The TbUnit type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TbUnit Class
Toolbox.Docking.Api.Units Namespace


Toolbox.Docking.Client.Interfaces Namespace

Interfaces
 | Interface | Description
Public interface | ITbChemical | Toolbox chemical
Public interface | ITbChemList | Definition for a Toolbox list
Public interface | ITbClient | Toolbox client information
Public interface | ITbDocument | Toolbox document information
Public interface | ITbExplainData | Data explain item definition
Public interface | ITbExtraActionInputState | Definition of the UI state for the extra action input
Public interface | ITbTreeNode | Definition for a node in Toolbox's endpoint tree.
Public interface | ITbUiState | UI state provider object.


ITbChemical Interface

Toolbox chemical

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbChemical

The ITbChemical type exposes the following members.

Properties
 | Name | Description
Public property | CasNo | Chemical Abstract Number for the structure.
Public property | Id | Persisting identifier for the chemical.
Public property | Smiles | SMILES representation for the structure.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbChemical Properties

The ITbChemical type exposes the following members.

Properties
 | Name | Description
Public property | CasNo | Chemical Abstract Number for the structure.
Public property | Id | Persisting identifier for the chemical.
Public property | Smiles | SMILES representation for the structure.
Top
See Also

Reference

ITbChemical Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemical.CasNo Property

ITbChemicalCasNo Property

Chemical Abstract Number for the structure.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
int CasNo { get; }

Property Value

Type: Int32
See Also

Reference

ITbChemical Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemical.Id Property

ITbChemicalId Property

Persisting identifier for the chemical.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

ITbChemical Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemical.Smiles Property

ITbChemicalSmiles Property

SMILES representation for the structure.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Smiles { get; }

Property Value

Type: String
See Also

Reference

ITbChemical Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemList Interface

Definition for a Toolbox list

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbChemList

The ITbChemList type exposes the following members.

Properties
 | Name | Description
Public property | ListCaption | Chemical list caption, to be used for UI purposes.
Public property | RunningTaskName | The name of the task currently operation on the chemical list
Public property | TargetChemical | Target for chemical list.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbChemList Properties

The ITbChemList type exposes the following members.

Properties
 | Name | Description
Public property | ListCaption | Chemical list caption, to be used for UI purposes.
Public property | RunningTaskName | The name of the task currently operation on the chemical list
Public property | TargetChemical | Target for chemical list.
Top
See Also

Reference

ITbChemList Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemList.ListCaption Property

ITbChemListListCaption Property

Chemical list caption, to be used for UI purposes.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string ListCaption { get; }

Property Value

Type: String
See Also

Reference

ITbChemList Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemList.RunningTaskName Property

ITbChemListRunningTaskName Property

The name of the task currently operation on the chemical list

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string RunningTaskName { get; }

Property Value

Type: String
See Also

Reference

ITbChemList Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbChemList.TargetChemical Property

ITbChemListTargetChemical Property

Target for chemical list.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbChemical TargetChemical { get; }

Property Value

Type: ITbChemical
See Also

Reference

ITbChemList Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbClient Interface

Toolbox client information

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbClient

The ITbClient type exposes the following members.

Properties
 | Name | Description
Public property | ClientId | Client's ID
Public property | ServerMode | Mode of the Server the Client is connected to.
Public property | SessionId | Session ID of the Client-Server connection
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbClient Properties

The ITbClient type exposes the following members.

Properties
 | Name | Description
Public property | ClientId | Client's ID
Public property | ServerMode | Mode of the Server the Client is connected to.
Public property | SessionId | Session ID of the Client-Server connection
Top
See Also

Reference

ITbClient Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbClient.ClientId Property

ITbClientClientId Property

Client's ID

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Guid ClientId { get; }

Property Value

Type: Guid
See Also

Reference

ITbClient Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbClient.ServerMode Property

ITbClientServerMode Property

Mode of the Server the Client is connected to.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
TbServerMode ServerMode { get; }

Property Value

Type: TbServerMode
See Also

Reference

ITbClient Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbClient.SessionId Property

ITbClientSessionId Property

Session ID of the Client-Server connection

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Guid SessionId { get; }

Property Value

Type: Guid
See Also

Reference

ITbClient Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbDocument Interface

Toolbox document information

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbDocument

The ITbDocument type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption that will be used for UI purposes.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbDocument Properties

The ITbDocument type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Caption that will be used for UI purposes.
Top
See Also

Reference

ITbDocument Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbDocument.Caption Property

ITbDocumentCaption Property

Caption that will be used for UI purposes.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Caption { get; }

Property Value

Type: String
See Also

Reference

ITbDocument Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExplainData Interface

Data explain item definition

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbExplainData : ITbUiState

The ITbExplainData type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical. (Inherited from ITbUiState.)
Public property | CurrentDocument | Currently selected document. (Inherited from ITbUiState.)
Public property | CurrentList | Currently selected list. (Inherited from ITbUiState.)
Public property | EndpointTree | Current document's selected endpoint tree. (Inherited from ITbUiState.)
Public property | ProducerObject | The object that produced the explained text.
Public property | Smiles | SMILES context of the result
Public property | TbClient | Toolbox Client information. (Inherited from ITbUiState.)
Public property | TextToExplain | Result to be explained.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbExplainData Properties

The ITbExplainData type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical. (Inherited from ITbUiState.)
Public property | CurrentDocument | Currently selected document. (Inherited from ITbUiState.)
Public property | CurrentList | Currently selected list. (Inherited from ITbUiState.)
Public property | EndpointTree | Current document's selected endpoint tree. (Inherited from ITbUiState.)
Public property | ProducerObject | The object that produced the explained text.
Public property | Smiles | SMILES context of the result
Public property | TbClient | Toolbox Client information. (Inherited from ITbUiState.)
Public property | TextToExplain | Result to be explained.
Top
See Also

Reference

ITbExplainData Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExplainData.ProducerObject Property

ITbExplainDataProducerObject Property

The object that produced the explained text.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbObjectId ProducerObject { get; }

Property Value

Type: ITbObjectId
See Also

Reference

ITbExplainData Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExplainData.Smiles Property

ITbExplainDataSmiles Property

SMILES context of the result

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string Smiles { get; }

Property Value

Type: String
See Also

Reference

ITbExplainData Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExplainData.TextToExplain Property

ITbExplainDataTextToExplain Property

Result to be explained.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
string TextToExplain { get; }

Property Value

Type: String
See Also

Reference

ITbExplainData Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExtraActionInputState Interface

Definition of the UI state for the extra action input

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbExtraActionInputState : ITbUiState

The ITbExtraActionInputState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical. (Inherited from ITbUiState.)
Public property | CurrentDocument | Currently selected document. (Inherited from ITbUiState.)
Public property | CurrentList | Currently selected list. (Inherited from ITbUiState.)
Public property | EndpointTree | Current document's selected endpoint tree. (Inherited from ITbUiState.)
Public property | TbClient | Toolbox Client information. (Inherited from ITbUiState.)
Public property | ToolboxObject | ID for the Toolbox object.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbExtraActionInputState Properties

The ITbExtraActionInputState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical. (Inherited from ITbUiState.)
Public property | CurrentDocument | Currently selected document. (Inherited from ITbUiState.)
Public property | CurrentList | Currently selected list. (Inherited from ITbUiState.)
Public property | EndpointTree | Current document's selected endpoint tree. (Inherited from ITbUiState.)
Public property | TbClient | Toolbox Client information. (Inherited from ITbUiState.)
Public property | ToolboxObject | ID for the Toolbox object.
Top
See Also

Reference

ITbExtraActionInputState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbExtraActionInputState.ToolboxObject Property

ITbExtraActionInputStateToolboxObject Property

ID for the Toolbox object.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbObjectId ToolboxObject { get; }

Property Value

Type: ITbObjectId
See Also

Reference

ITbExtraActionInputState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbTreeNode Interface

Definition for a node in Toolbox's endpoint tree.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbTreeNode

The ITbTreeNode type exposes the following members.

Properties
 | Name | Description
Public property | Path | The path to the tree node startinг from the top level e.g.: Human Health Hazards Sensitisation
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbTreeNode Properties

The ITbTreeNode type exposes the following members.

Properties
 | Name | Description
Public property | Path | The path to the tree node startinг from the top level e.g.: Human Health Hazards Sensitisation
Top
See Also

Reference

ITbTreeNode Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbTreeNode.Path Property

ITbTreeNodePath Property

The path to the tree node startinг from the top level e.g.: Human Health Hazards Sensitisation

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
IReadOnlyList<string> Path { get; }

Property Value

Type: IReadOnlyList String
See Also

Reference

ITbTreeNode Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState Interface

UI state provider object.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbUiState

The ITbUiState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical.
Public property | CurrentDocument | Currently selected document.
Public property | CurrentList | Currently selected list.
Public property | EndpointTree | Current document's selected endpoint tree.
Public property | TbClient | Toolbox Client information.
Top
See Also

Reference

Toolbox.Docking.Client.Interfaces Namespace


ITbUiState Properties

The ITbUiState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentChemical | Currently selected chemical.
Public property | CurrentDocument | Currently selected document.
Public property | CurrentList | Currently selected list.
Public property | EndpointTree | Current document's selected endpoint tree.
Public property | TbClient | Toolbox Client information.
Top
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState.CurrentChemical Property

ITbUiStateCurrentChemical Property

Currently selected chemical.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbChemical CurrentChemical { get; }

Property Value

Type: ITbChemical
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState.CurrentDocument Property

ITbUiStateCurrentDocument Property

Currently selected document.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbDocument CurrentDocument { get; }

Property Value

Type: ITbDocument
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState.CurrentList Property

ITbUiStateCurrentList Property

Currently selected list.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbChemList CurrentList { get; }

Property Value

Type: ITbChemList
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState.EndpointTree Property

ITbUiStateEndpointTree Property

Current document's selected endpoint tree.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbTreeNode EndpointTree { get; }

Property Value

Type: ITbTreeNode
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


ITbUiState.TbClient Property

ITbUiStateTbClient Property

Toolbox Client information.

Namespace: Toolbox.Docking.Client.Interfaces
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbClient TbClient { get; }

Property Value

Type: ITbClient
See Also

Reference

ITbUiState Interface
Toolbox.Docking.Client.Interfaces Namespace


Toolbox.Docking.Client.Plugins Namespace

Interfaces
 | Interface | Description
Public interface | ITbClientPlugin | Plugin module which will be activated when an extra action is activated in case TbExtraActionDefinition.ClientModule is assigned.
Public interface | ITbDomainVisualizer | Plugin module for visualizing of domain. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbDomainVisualizer))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbQsarFactory.ClientDomainExplainer Modules are loaded using Managed Extensibility Framework (MEF).
Public interface | ITbExtraActionResultExplainPlugin | Client side explainer for third party addin results.
Public interface | ITbObjectVisualizer | Plugin module for visualizing of domain. The classes which implement this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbDomainVisualizer))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbQsarFactory.ClientDomainExplainer Modules are loaded using Managed Extensibility Framework (MEF).
Public interface | ITbOptionsPlugin | Plugin module for explaining results. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbOptionsPlugin))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbObjectFactoryTunable.ClientOptionsModule Modules are loaded using Managed Extensibility Framework (MEF).
Public interface | ITbResultExplainer | Plugin module for explaining results. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(IToolboxPlugin))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbObjectFactoryExplain.ClientExplainModule Modules are loaded using Managed Extensibility Framework (MEF).


ITbClientPlugin Interface

Plugin module which will be activated when an extra action is activated in case TbExtraActionDefinition.ClientModule is assigned.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbClientPlugin

The ITbClientPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ClientPluginExecute | Execute client side plugin.
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbClientPlugin Methods

The ITbClientPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ClientPluginExecute | Execute client side plugin.
Top
See Also

Reference

ITbClientPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbClientPlugin.ClientPluginExecute Method

ITbClientPluginClientPluginExecute Method

Execute client side plugin.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task ClientPluginExecute(
    ITbClientServiceLocator clientServices,
    ITbExtraActionInputState input
)

Parameters

clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Service locator object.
input
Type: Toolbox.Docking.Client.InterfacesITbExtraActionInputState
UI input state

Return Value

Type: Task
Returns C# Task object for async support.
See Also

Reference

ITbClientPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbDomainVisualizer Interface

Plugin module for visualizing of domain. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbDomainVisualizer))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbQsarFactory.ClientDomainExplainer Modules are loaded using Managed Extensibility Framework (MEF).

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbDomainVisualizer

The ITbDomainVisualizer type exposes the following members.

Methods
 | Name | Description
Public method | DisplayDomain | Displays the domain for a Toolbox addin.
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbDomainVisualizer Methods

The ITbDomainVisualizer type exposes the following members.

Methods
 | Name | Description
Public method | DisplayDomain | Displays the domain for a Toolbox addin.
Top
See Also

Reference

ITbDomainVisualizer Interface
Toolbox.Docking.Client.Plugins Namespace


ITbDomainVisualizer.DisplayDomain Method

ITbDomainVisualizerDisplayDomain Method

Displays the domain for a Toolbox addin.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task DisplayDomain(
    ITbObjectId qsarId,
    ITbUiState uiState,
    ITbClientServiceLocator clientServices
)

Parameters

qsarId
Type: Toolbox.DeclarationsITbObjectId
The ID for the QSAR object for which a domain will be displayed
uiState
Type: Toolbox.Docking.Client.InterfacesITbUiState
The item that will be explained by the Domain. If there is no chemical set the Domain is shown without example chemical.
clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Toolbox services provider.

Return Value

Type: Task
Returns the C# Task for async support.
See Also

Reference

ITbDomainVisualizer Interface
Toolbox.Docking.Client.Plugins Namespace


ITbExtraActionResultExplainPlugin Interface

Client side explainer for third party addin results.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbExtraActionResultExplainPlugin

The ITbExtraActionResultExplainPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ExplainExtraActionResult | Method that explains the third party addin result.
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbExtraActionResultExplainPlugin Methods

The ITbExtraActionResultExplainPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ExplainExtraActionResult | Method that explains the third party addin result.
Top
See Also

Reference

ITbExtraActionResultExplainPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbExtraActionResultExplainPlugin.ExplainExtraActionResult Method

ITbExtraActionResultExplainPluginExplainExtraActionResult Method

Method that explains the third party addin result.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task ExplainExtraActionResult(
    ITbClientServiceLocator clientServices,
    ITbExtraActionInputState input,
    ITbExtraActionResult toExplain
)

Parameters

clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Toolbox services provider.
input
Type: Toolbox.Docking.Client.InterfacesITbExtraActionInputState
Current state of the Client UI
toExplain
Type: Toolbox.DeclarationsITbExtraActionResult
The item that will be explained by the client side explainer.

Return Value

Type: Task
Async C# Task for explainer.
See Also

Reference

ITbExtraActionResultExplainPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbObjectVisualizer Interface

Plugin module for visualizing of domain. The classes which implement this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbDomainVisualizer))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbQsarFactory.ClientDomainExplainer Modules are loaded using Managed Extensibility Framework (MEF).

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbObjectVisualizer

The ITbObjectVisualizer type exposes the following members.

Methods
 | Name | Description
Public method | DisplayObject | Displays the domain for a Toolbox addin.
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbObjectVisualizer Methods

The ITbObjectVisualizer type exposes the following members.

Methods
 | Name | Description
Public method | DisplayObject | Displays the domain for a Toolbox addin.
Top
See Also

Reference

ITbObjectVisualizer Interface
Toolbox.Docking.Client.Plugins Namespace


ITbObjectVisualizer.DisplayObject Method

ITbObjectVisualizerDisplayObject Method

Displays the domain for a Toolbox addin.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task DisplayObject(
    ITbObjectId objectId,
    ITbUiState uiState,
    ITbClientServiceLocator clientServices
)

Parameters

objectId
Type: Toolbox.DeclarationsITbObjectId
The ID for the object for which a domain will be displayed
uiState
Type: Toolbox.Docking.Client.InterfacesITbUiState
The current state, if needed for visualization.
clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Toolbox services provider.

Return Value

Type: Task
Returns the C# Task for async support.
See Also

Reference

ITbObjectVisualizer Interface
Toolbox.Docking.Client.Plugins Namespace


ITbOptionsPlugin Interface

Plugin module for explaining results. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(ITbOptionsPlugin))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbObjectFactoryTunable.ClientOptionsModule Modules are loaded using Managed Extensibility Framework (MEF).

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbOptionsPlugin

The ITbOptionsPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteOptions | Display optionf for a Toolbox object.
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbOptionsPlugin Methods

The ITbOptionsPlugin type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteOptions | Display optionf for a Toolbox object.
Top
See Also

Reference

ITbOptionsPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbOptionsPlugin.ExecuteOptions Method

ITbOptionsPluginExecuteOptions Method

Display optionf for a Toolbox object.

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<string> ExecuteOptions(
    ITbUiState uiState,
    ITbObjectId tbObjectId,
    string options,
    ITbClientServiceLocator clientServices
)

Parameters

uiState
Type: Toolbox.Docking.Client.InterfacesITbUiState
Current UI state for the Toolbox Client
tbObjectId
Type: Toolbox.DeclarationsITbObjectId
The Toolbox object ID
options
Type: SystemString
Options, encoded as string, to be displayed.
clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Service locator object.

Return Value

Type: Task String
Return new options or null
See Also

Reference

ITbOptionsPlugin Interface
Toolbox.Docking.Client.Plugins Namespace


ITbResultExplainer Interface

Plugin module for explaining results. The classes which implements this interface must have these two attributes: [Export([PLUGIN_NAME], typeof(IToolboxPlugin))] [PartCreationPolicy(CreationPolicy.NonShared)] [PLUGIN_NAME] must correspond to server's implementation of: ITbObjectFactoryExplain.ClientExplainModule Modules are loaded using Managed Extensibility Framework (MEF).

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbResultExplainer

The ITbResultExplainer type exposes the following members.

Methods
 | Name | Description
Public method | Explain | Explains a addin result item
Top
See Also

Reference

Toolbox.Docking.Client.Plugins Namespace


ITbResultExplainer Methods

The ITbResultExplainer type exposes the following members.

Methods
 | Name | Description
Public method | Explain | Explains a addin result item
Top
See Also

Reference

ITbResultExplainer Interface
Toolbox.Docking.Client.Plugins Namespace


ITbResultExplainer.Explain Method

ITbResultExplainerExplain Method

Explains a addin result item

Namespace: Toolbox.Docking.Client.Plugins
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task Explain(
    ITbExplainData subject,
    ITbClientServiceLocator clientServices
)

Parameters

subject
Type: Toolbox.Docking.Client.InterfacesITbExplainData
The subject for explainer.
clientServices
Type: Toolbox.Docking.Client.ServicesITbClientServiceLocator
Service resolver.

Return Value

Type: Task
Task object for the async explainer.
See Also

Reference

ITbResultExplainer Interface
Toolbox.Docking.Client.Plugins Namespace


Toolbox.Docking.Client.Services Namespace

Interfaces
 | Interface | Description
Public interface | ITbClientServiceLocator | Service injection, service location
Public interface | ITbDialogService | UI services provider.
Public interface | ITbExtraActionService | Provides chanel a client module to communicate with server party


ITbClientServiceLocator Interface

Service injection, service location

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbClientServiceLocator

The ITbClientServiceLocator type exposes the following members.

Properties
 | Name | Description
Public property | DialogService | The DialogService provides various UI services.
Public property | ExtraActionService | Service for executing an extra Toolbox action.
Top
See Also

Reference

Toolbox.Docking.Client.Services Namespace


ITbClientServiceLocator Properties

The ITbClientServiceLocator type exposes the following members.

Properties
 | Name | Description
Public property | DialogService | The DialogService provides various UI services.
Public property | ExtraActionService | Service for executing an extra Toolbox action.
Top
See Also

Reference

ITbClientServiceLocator Interface
Toolbox.Docking.Client.Services Namespace


ITbClientServiceLocator.DialogService Property

ITbClientServiceLocatorDialogService Property

The DialogService provides various UI services.

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbDialogService DialogService { get; }

Property Value

Type: ITbDialogService
See Also

Reference

ITbClientServiceLocator Interface
Toolbox.Docking.Client.Services Namespace


ITbClientServiceLocator.ExtraActionService Property

ITbClientServiceLocatorExtraActionService Property

Service for executing an extra Toolbox action.

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
ITbExtraActionService ExtraActionService { get; }

Property Value

Type: ITbExtraActionService
See Also

Reference

ITbClientServiceLocator Interface
Toolbox.Docking.Client.Services Namespace


ITbDialogService Interface

UI services provider.

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbDialogService

The ITbDialogService type exposes the following members.

Methods
 | Name | Description
Public method | Confirm | Displays a Request confirmation dialog to the user
Public method | Show | Displays a non-modal window. For any window shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the window 2. The dialog will be positioned at the center of it's Owner (The Shell)
Public method | ShowDialog | Displays a modal window. For any dialog shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the dialog 2. The dialog will be positioned at the center of it's Owner (The Shell)
Public method | ShowMessage | Use this instead MessageBox.Show(), which happens to be non-modal for unknown reasons
Top
See Also

Reference

Toolbox.Docking.Client.Services Namespace


ITbDialogService Methods

The ITbDialogService type exposes the following members.

Methods
 | Name | Description
Public method | Confirm | Displays a Request confirmation dialog to the user
Public method | Show | Displays a non-modal window. For any window shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the window 2. The dialog will be positioned at the center of it's Owner (The Shell)
Public method | ShowDialog | Displays a modal window. For any dialog shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the dialog 2. The dialog will be positioned at the center of it's Owner (The Shell)
Public method | ShowMessage | Use this instead MessageBox.Show(), which happens to be non-modal for unknown reasons
Top
See Also

Reference

ITbDialogService Interface
Toolbox.Docking.Client.Services Namespace


ITbDialogService.Confirm Method

ITbDialogServiceConfirm Method

Displays a Request confirmation dialog to the user

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool Confirm(
    string message,
    string title = null,
    bool skippable = false,
    TextAlignment messageAlignment = TextAlignment.Center,
    int width = 550,
    int height = 200
)

Parameters

message
Type: SystemString
The question to be asked
title (Optional)
Type: SystemString
Title caption for the dialog.
skippable (Optional)
Type: SystemBoolean
Will skip dialog option be provided.
messageAlignment (Optional)
Type: System.WindowsTextAlignment
TextAlignment for the message.
width (Optional)
Type: SystemInt32
Width for the dialog.
height (Optional)
Type: SystemInt32
Height for the dialog.

Return Value

Type: Boolean
True, if the user agree
See Also

Reference

ITbDialogService Interface
Toolbox.Docking.Client.Services Namespace


ITbDialogService.Show Method

ITbDialogServiceShow Method

Displays a non-modal window. For any window shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the window 2. The dialog will be positioned at the center of it's Owner (The Shell)

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void Show(
    Window window,
    WindowStartupLocation location = WindowStartupLocation.CenterOwner
)

Parameters

window
Type: System.WindowsWindow
The window to be displayed.
location (Optional)
Type: System.WindowsWindowStartupLocation
Preferred startup location
See Also

Reference

ITbDialogService Interface
Toolbox.Docking.Client.Services Namespace


ITbDialogService.ShowDialog Method

ITbDialogServiceShowDialog Method

Displays a modal window. For any dialog shown by this method, the following is guaranteed to be true: 1. The Shell (MainWindow) will take ownership of the dialog 2. The dialog will be positioned at the center of it's Owner (The Shell)

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
bool ShowDialog(
    Window dialog,
    WindowStartupLocation location = WindowStartupLocation.CenterOwner
)

Parameters

dialog
Type: System.WindowsWindow
The window to be displayed.
location (Optional)
Type: System.WindowsWindowStartupLocation
Preferred startup location

Return Value

Type: Boolean
Return the result of dialog.ShowDialog
See Also

Reference

ITbDialogService Interface
Toolbox.Docking.Client.Services Namespace


ITbDialogService.ShowMessage Method

ITbDialogServiceShowMessage Method

Use this instead MessageBox.Show(), which happens to be non-modal for unknown reasons

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
void ShowMessage(
    string msg,
    string title,
    IEnumerable<KeyValuePair<string, string>> additionalInfo = null,
    TextAlignment msgAlignment = TextAlignment.Center
)

Parameters

msg
Type: SystemString
Text for the displayed message.
title
Type: SystemString
Title caption for the dialog.
additionalInfo (Optional)
Type: System.Collections.GenericIEnumerable KeyValuePair String, String
Key value pairs which will be rendered as additional message information
msgAlignment (Optional)
Type: System.WindowsTextAlignment
Shows how to align the message in the dialog
See Also

Reference

ITbDialogService Interface
Toolbox.Docking.Client.Services Namespace


ITbExtraActionService Interface

Provides chanel a client module to communicate with server party

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
public interface ITbExtraActionService

The ITbExtraActionService type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteExtraAction | Method for executing addin extra actions.
Top
See Also

Reference

Toolbox.Docking.Client.Services Namespace


ITbExtraActionService Methods

The ITbExtraActionService type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteExtraAction | Method for executing addin extra actions.
Top
See Also

Reference

ITbExtraActionService Interface
Toolbox.Docking.Client.Services Namespace


ITbExtraActionService.ExecuteExtraAction Method

ITbExtraActionServiceExecuteExtraAction Method

Method for executing addin extra actions.

Namespace: Toolbox.Docking.Client.Services
Assembly: Toolbox.Docking.Client (in Toolbox.Docking.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
Copy
Task<ITbExtraActionResult> ExecuteExtraAction(
    ITbUiState uiState,
    string actionCaption,
    Guid tbObjectId,
    Guid actionId,
    int command,
    string payload
)

Parameters

uiState
Type: Toolbox.Docking.Client.InterfacesITbUiState
Current state of the Client UI.
actionCaption
Type: SystemString
The UI presentable name of the action being executed.
tbObjectId
Type: SystemGuid
The identifier of the executing Toolbox object.
actionId
Type: SystemGuid
The ID of the executed action.
command
Type: SystemInt32
Command variant.
payload
Type: SystemString
String encoded payload for the action.

Return Value

Type: Task ITbExtraActionResult
Returns source template wrapped as a C# Task for async support.
See Also

Reference

ITbExtraActionService Interface
Toolbox.Docking.Client.Services Namespace